Bug 1032761 - Schema Validation errors when offline
Schema Validation errors when offline
Status: CLOSED CURRENTRELEASE
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: SwitchYard Editor (Show other bugs)
6.0.0 GA
Unspecified Unspecified
unspecified Severity medium
: CR2
: ---
Assigned To: Rob Cernich
Andrej Podhradsky
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-20 14:22 EST by Jim Rigsbee
Modified: 2014-06-16 19:49 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Simple SY Maven project to demonstrate schema validation errors (4.50 KB, application/zip)
2013-11-20 14:22 EST, Jim Rigsbee
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker SWITCHYARD-1854 Major Closed Schema Validation errors when offline 2014-06-16 19:49:52 EDT

  None (edit)
Description Jim Rigsbee 2013-11-20 14:22:09 EST
Created attachment 826812 [details]
Simple SY Maven project to demonstrate schema validation errors

Description of problem:
When there is no internet connectivity the attached project gets several schema validation errors in the switchyard.xml file - namely schema sca-binding-ws-1.1-cd04-rev2.xsd.

When the internet is connected these errors do not appear.

Note that all JBoss Training classrooms run offline due to many customer restrictions regarding internet access onsite.  so offline is the normal mode of testing and final validation of a training class.

Note these errors occur even if the Honor All Schema.... is unchecked.

Version-Release number of selected component (if applicable):
FSW 6 Beta 1

How reproducible:
Always when offline

Steps to Reproduce:
1. Have internet connected
2. Build the attached project at the command line - mvn clean package
3. Disconnect internet 
4. Start JBDS
5. Import the project as an "existing Maven project"
6. After build and validation the schema errors will be reported

Actual results:
Schema errors are reported (and can be safely ignored)

Expected results:
No schema errors reported

Additional info:
Although this is low priority - it makes the product look broken and may cause quite a bit of confusion
Comment 2 JBoss JIRA Server 2013-11-22 12:42:36 EST
Keith Babo <kbabo@redhat.com> updated the status of jira SWITCHYARD-1854 to Resolved
Comment 3 JBoss JIRA Server 2013-11-22 12:42:36 EST
Keith Babo <kbabo@redhat.com> made a comment on jira SWITCHYARD-1854

pushed
Comment 4 Andrej Podhradsky 2013-12-18 12:36:48 EST
Verified with JBDS-IS 7.0.0.CR1
Comment 5 JBoss JIRA Server 2014-06-16 19:49:52 EDT
Keith Babo <kbabo@redhat.com> updated the status of jira SWITCHYARD-1854 to Closed

Note You need to log in before you can comment on or make changes to this bug.