Bug 1032781 - App status is shown as "Unknown" and unable to restart the app. [NEEDINFO]
App status is shown as "Unknown" and unable to restart the app.
Status: CLOSED INSUFFICIENT_DATA
Product: OpenShift Online
Classification: Red Hat
Component: Website (Show other bugs)
2.x
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jordan Liggitt
libra bugs
: UpcomingRelease
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-20 15:16 EST by Hasif
Modified: 2015-05-14 21:31 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-02 11:45:28 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
jliggitt: needinfo? (haasaif)


Attachments (Terms of Use)
The image shows my app console. (117.29 KB, image/png)
2013-11-20 15:16 EST, Hasif
no flags Details

  None (edit)
Description Hasif 2013-11-20 15:16:00 EST
Created attachment 826829 [details]
The image shows my app console.

Description of problem:
The app status is shown as "Unkonwn" and also unable to restart the app. When tried to restart the console is redirected to this url: 
https://openshift.redhat.com/app/console/server_unavailable

I was able to build the app from the rhc client. But when tried to restart from rhc client i got the following error "Server returned an unexpected error code: 504".

After building from rhc, the app is up and running.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.Pushed the code into git.
2.Restarted the application
3.

Actual results:
App status "Unknown" and app is running fine.

Expected results:
App status "Started".

Additional info:
Comment 1 Jordan Liggitt 2013-11-21 11:15:58 EST
Can you recreate the issue? If so, can you run the rhc restart command that is failing in debug mode, and include the results (minus any authorization headers)?

HTTP_DEBUG=1 rhc -d app restart APP_NAME 2>&1 | grep -v authorization:
Comment 2 Jordan Liggitt 2013-12-02 11:45:28 EST
Closing. If you can recreate or provide more details, please reopen.

Note You need to log in before you can comment on or make changes to this bug.