Bug 1032786 - Teiid Quickstarts contain both parent and dependencyManagement
Teiid Quickstarts contain both parent and dependencyManagement
Status: CLOSED CURRENTRELEASE
Product: JBoss Data Virtualization 6
Classification: JBoss
Component: Productization, Teiid (Show other bugs)
unspecified
Unspecified Unspecified
high Severity medium
: GA
: 6.0
Assigned To: Van Halbert
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-20 15:27 EST by Julian Coleman
Modified: 2014-07-09 01:00 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-10 15:54:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Julian Coleman 2013-11-20 15:27:49 EST
The teiid-quickstarts (version 1.1.0) top-level pom.xml contains both a parent section (org.jboss.teiid:teiid-parent), and also a dependencyManagement section.  This is problematic because realigning the versions for a product build aligns to product versions via teiid-parent, but the local dependencyManagement section causes some no-product versions to be used instead (i.e. overriding the previous alignment).

The fix is to only have a dependencyManagement section in the parent (teiid-parent) and no dependencyManagement sections in any POM that references that parent.  Making the common parent a separate build is commonly used for this.

This has been worked around by forcing the teiid-quickstarts to have the IP BOM as parent, but that is not ideal.
Comment 2 belong 2013-12-01 20:51:11 EST
I assume this does not need to be documented as a known issue in Release Notes - setting to requires_doc_text- accordingly.

Note You need to log in before you can comment on or make changes to this bug.