Bug 1032805 - System Can't Claim SCSI Scanner
System Can't Claim SCSI Scanner
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: sane-backends (Show other bugs)
7.0
x86_64 Linux
unspecified Severity medium
: rc
: ---
Assigned To: Nils Philippsen
BaseOS QE - Apps
:
Depends On: 1028549
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-20 16:31 EST by Nils Philippsen
Modified: 2014-06-18 03:23 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1028549
Environment:
Last Closed: 2014-06-16 06:22:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 919874 None None None Never

  None (edit)
Description Nils Philippsen 2013-11-20 16:31:30 EST
+++ This bug was initially created as a clone of Bug #1028549 +++

Description of problem:
SCSI Scanner not recognized by system

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Boot system
2.Run sane.
3.

Actual results:
No scanner

Expected results:
Should see scanner

Additional info:

--- Additional comment from Nils Philippsen on 2013-11-14 05:50:51 EST ---

This bug report is missing essential information:

- What type of scanner is this?
- Please post the output of the following commands:

cat /proc/scsi/scsi
ls -lZ /dev/sg*

--- Additional comment from Nils Philippsen on 2013-11-14 06:00:00 EST ---

Ahh, it's probably the scanner you mentioned in bug #919874, a Umax Astra 2400S attached to a Domex 536 SCSI host adapter. I'll still need the output of the two commands from comment #1, thanks!

--- Additional comment from Nils Philippsen on 2013-11-14 06:06:43 EST ---



--- Additional comment from KitchM on 2013-11-14 10:32:28 EST ---

Umax Astra 2400S

Attached devices:
Host: scsi4 Channel: 00 Id: 01 Lun: 00
  Vendor: UMAX     Model: Astra 2400S      Rev: V1.1
  Type:   Scanner                          ANSI  SCSI revision: 02
Host: scsi0 Channel: 00 Id: 00 Lun: 00
  Vendor: ATA      Model: WDC WD400EB-00CP Rev: 06.0
  Type:   Direct-Access                    ANSI  SCSI revision: 05
Host: scsi1 Channel: 00 Id: 00 Lun: 00
  Vendor: PLEXTOR  Model: CD-R   PX-W2410A Rev: 1.02
  Type:   CD-ROM                           ANSI  SCSI revision: 05
Host: scsi1 Channel: 00 Id: 01 Lun: 00
  Vendor: ASUS     Model: DRW-1814BL       Rev: 1.14
  Type:   CD-ROM                           ANSI  SCSI revision: 05
Host: scsi2 Channel: 00 Id: 00 Lun: 00
  Vendor: ATA      Model: KINGSTON SV300S3 Rev: 505A
  Type:   Direct-Access                    ANSI  SCSI revision: 05


crw-------  root root  ?                                /dev/sg0
crw-rw----  root disk  ?                                /dev/sg2
crw-rw----+ root cdrom ?                                /dev/sg3
crw-rw----+ root cdrom ?                                /dev/sg4
crw-rw----  root disk  ?                                /dev/sg5


Thank you.

--- Additional comment from Nils Philippsen on 2013-11-15 11:30:42 EST ---

It seems as if the permissions of your scanner device /dev/sg0 aren't set up correctly. Please run the following command for me (as root) and post the output:

udevadm info --query=all /dev/sg0

We need to find out what udev makes of this device.

--- Additional comment from KitchM on 2013-11-15 12:13:07 EST ---

Here's the response:

P: /devices/pci0000:00/0000:00:06.0/ata1/host0/target0:0:0/0:0:0:0/scsi_generic/sg0
N: sg0
E: DEVNAME=/dev/sg0
E: DEVPATH=/devices/pci0000:00/0000:00:06.0/ata1/host0/target0:0:0/0:0:0:0/scsi_generic/sg0
E: MAJOR=21
E: MINOR=0
E: SUBSYSTEM=scsi_generic




Thanks much.

--- Additional comment from Nils Philippsen on 2013-11-20 16:10:42 EST ---

Sorry for the wait but I think that I have found the cause of your problem in the meantime (I could reproduce the issue with my own SCSI hardware):

- The udev rules shipped with sane-backends seem to have ceased working, I can only speculate that this is due to some changes in sysfs.
- This resulted in the system not recognizing your scanner as such, i.e. not giving your user the necessary permissions on its SCSI generic device file.
- I've modified my local udev rules and with the changes I did, my SCSI scanner was again recognized as such, and the device file got the proper permissions.

I've committed a patch upstream and will build packages containing the fix shortly.
Comment 5 Ludek Smid 2014-06-16 06:22:17 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.