Bug 1032819 - broadcast address not configured
broadcast address not configured
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
20
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
: 1038959 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-20 17:39 EST by Louis Lagendijk
Modified: 2014-01-23 09:11 EST (History)
6 users (show)

See Also:
Fixed In Version: NetworkManager-0.9.9.0-22.git20131003.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1034900 (view as bug list)
Environment:
Last Closed: 2013-12-22 00:36:34 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Louis Lagendijk 2013-11-20 17:39:16 EST
Description of problem:
The broadcast address is not set on my interfaces. After system start my interfaces have 0.0.0.0 as broadcast address

Version-Release number of selected component (if applicable):
F20 with all updates installed as of 2013-11-20

How reproducible:


Steps to Reproduce:
1.Start the system
2. in a terminal type: ifconfig p5p1


Actual results:
Broadcast address set to 0.0.0.0

Expected results:
Broadcast address set (for my 192.168.159.3 address: 192.168.159.255)

Additional info:
This issue occurs on my desktop system that has been installed with one of the TC's for Alpha, but I now see the same on my laptop that I installed with Fedora 20 Beta
Comment 1 Louis Lagendijk 2013-11-20 17:41:39 EST
This issue occurs on the ethernet interfaces as well on the WLan on the laptop
Comment 2 Dan Williams 2013-12-03 15:25:37 EST
upstream commit 7eb12a5b21f87d7592ec2c5235d1ed90c4fac132
Comment 3 Andy Wang 2013-12-18 11:47:06 EST
Is there a workaround for this issue short of manually configuring broadcast via ifconfig?  I have a few scenarios where broadcast needs to work properly.
Comment 4 Fedora Update System 2013-12-18 15:16:37 EST
NetworkManager-0.9.9.0-21.git20131003.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/NetworkManager-0.9.9.0-21.git20131003.fc20
Comment 5 Fedora Update System 2013-12-19 20:35:08 EST
Package NetworkManager-0.9.9.0-21.git20131003.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing NetworkManager-0.9.9.0-21.git20131003.fc20'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-23593/NetworkManager-0.9.9.0-21.git20131003.fc20
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2013-12-19 22:03:23 EST
NetworkManager-0.9.9.0-22.git20131003.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/NetworkManager-0.9.9.0-22.git20131003.fc20
Comment 7 Andy Wang 2013-12-20 11:00:01 EST
Woo hoo.  Fix worked for me.
Comment 8 Fedora Update System 2013-12-22 00:36:34 EST
NetworkManager-0.9.9.0-22.git20131003.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Thomas Woerner 2014-01-10 08:29:58 EST
*** Bug 1038959 has been marked as a duplicate of this bug. ***
Comment 10 raad.orfali 2014-01-23 09:11:10 EST
I have the NetworkManager-0.9.9.0-22.git20131003.fc20 version but I am still cannot access shared file only after disabling the firewall

Note You need to log in before you can comment on or make changes to this bug.