This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1032884 - failed to exec /.dockerinit
failed to exec /.dockerinit
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: docker-io (Show other bugs)
19
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Lokesh Mandvekar
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-21 02:06 EST by Lokesh Mandvekar
Modified: 2014-07-01 18:59 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-21 17:02:59 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lokesh Mandvekar 2013-11-21 02:06:50 EST
Description of problem: failed to exec /.dockerinit


Version-Release number of selected component (if applicable): 0.7-0.16.rc6.fc19


How reproducible: always


Steps to Reproduce:
1. sudo docker run -i -t mattdm/fedora /bin/bash


Actual results:
$ sudo docker run -i -t mattdm/fedora /bin/bash
lxc-start: No such file or directory - failed to exec /.dockerinit
lxc-start: invalid sequence number 1. expected 2
lxc-start: failed to spawn 'c5f0ffe8ef04bfd12b135de49465251142cdf5da4886ad8ec1aa00da052974e7'
[error] commands.go:2203 Error resize: Error: bad file descriptor

Expected results: should enter container shell


Additional info: I noticed this only after 2330 CST on 11/20, the same version was working fine before. Also been noticing something similar on my rawhide. 
I hope it's just me :\ . Anyway, throwing it out there, will check later.
Comment 1 Dan Mace 2013-11-21 16:39:28 EST
For more context, here's the similar error I'm receiving (docker-io-0.7-0.16.rc6.fc20.x86_64):

$ sudo docker run mattdm/fedora ping www.google.com                                                      
[sudo] password for dmace: 
lxc-start: No such file or directory - failed to exec /.dockerinit
lxc-start: invalid sequence number 1. expected 4
lxc-start: failed to spawn 'ed9a6b783bb011035bc89dc33eae449d32068d714b643112956eb5bf6e7d639a'
lxc-start: Device or resource busy - failed to remove cgroup '/sys/fs/cgroup/cpuset/lxc/ed9a6b783bb011035bc89dc33eae449d32068d714b643112956eb5bf6e7d639a'
lxc-start: Device or resource busy - failed to remove cgroup '/sys/fs/cgroup/cpu,cpuacct/lxc/ed9a6b783bb011035bc89dc33eae449d32068d714b643112956eb5bf6e7d639a'
lxc-start: Device or resource busy - failed to remove cgroup '/sys/fs/cgroup/memory/lxc/ed9a6b783bb011035bc89dc33eae449d32068d714b643112956eb5bf6e7d639a'
lxc-start: Device or resource busy - failed to remove cgroup '/sys/fs/cgroup/devices/lxc/ed9a6b783bb011035bc89dc33eae449d32068d714b643112956eb5bf6e7d639a'
lxc-start: Device or resource busy - failed to remove cgroup '/sys/fs/cgroup/freezer/lxc/ed9a6b783bb011035bc89dc33eae449d32068d714b643112956eb5bf6e7d639a'
lxc-start: Device or resource busy - failed to remove cgroup '/sys/fs/cgroup/net_cls/lxc/ed9a6b783bb011035bc89dc33eae449d32068d714b643112956eb5bf6e7d639a'
lxc-start: Device or resource busy - failed to remove cgroup '/sys/fs/cgroup/blkio/lxc/ed9a6b783bb011035bc89dc33eae449d32068d714b643112956eb5bf6e7d639a'
lxc-start: Device or resource busy - failed to remove cgroup '/sys/fs/cgroup/perf_event/lxc/ed9a6b783bb011035bc89dc33eae449d32068d714b643112956eb5bf6e7d639a'
Comment 2 Dan Mace 2013-11-21 16:56:15 EST
Resolved by rebuilding /var/lib/docker/*; old image metadata must not be compatible with the latest builds. Not a bug.

Note You need to log in before you can comment on or make changes to this bug.