Bug 1032888 - Fail to copy & paste whole ssh url with middle click on Firefox25
Fail to copy & paste whole ssh url with middle click on Firefox25
Status: CLOSED CANTFIX
Product: OpenShift Online
Classification: Red Hat
Component: Website (Show other bugs)
2.x
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Jordan Liggitt
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-21 02:23 EST by Tian Feng
Modified: 2015-05-14 21:31 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-21 12:26:01 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tian Feng 2013-11-21 02:23:34 EST
Description of problem:
Create an app and add ssh key. Go to app view page (i.e. app/console/application/<uuid>-<app_name>) and check ssh url. Then tried to copy&paste ssh url with middle click. Only can copy the word under mouse, fail to copy the whole ssh url although selecting all.

Version-Release number of selected component (if applicable):
devenv_4056

How reproducible:
Always

Steps to Reproduce:
1. Create an app and add ssh key
2. Go to app view page and try to copy & paste ssh url
3. 

Actual results:
Only can copy&paste the word under mouse with middle click, can't copy&paste whole ssh url althought selecting all.

Expected results:
Should copy&paste whole ssh url with middle click.

Additional info:
Comment 1 Jordan Liggitt 2013-11-21 10:09:34 EST
Will modify code to select text immediately on mousedown. Will merge in https://github.com/openshift/origin-server/pull/4216

Not sure if this will allow the OS to copy on middle-click, but it's the best we can do.
Comment 2 Jordan Liggitt 2013-11-21 12:26:01 EST
It looks like firefox will not allow middle-click to copy text out of the input field. Can close as cantfix since the browser doesn't appear to allow it.
Comment 3 openshift-github-bot 2013-11-21 15:25:24 EST
Commit pushed to master at https://github.com/openshift/origin-server

https://github.com/openshift/origin-server/commit/1d75b78a75a924c6e6e31207c6dee9867ecad0e7
Fix bug 1032888: select ssh url on mousedown

Note You need to log in before you can comment on or make changes to this bug.