Bug 1032920 - Some useless files about python-3.3 is installed on the node
Some useless files about python-3.3 is installed on the node
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Image (Show other bugs)
2.0.0
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Jason DeTiberus
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-21 04:11 EST by Gaoyun Pei
Modified: 2017-03-08 12 EST (History)
3 users (show)

See Also:
Fixed In Version: openshift-origin-cartridge-python-1.17.7-1.el6op
Doc Type: Bug Fix
Doc Text:
The Python cartridge included files and directories from the upstream community cartridge that were not applicable to OpenShift Enterprise. The unnecessary community files and directories have been removed from the current version of the Python cartridge.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-28 11:38:58 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gaoyun Pei 2013-11-21 04:11:04 EST
Description of problem:
After installing python-cartridge on the node, there would be some useless directory and files related to python-3.3-community cartridge, which is not supported by OSE-2.0

Version-Release number of selected component (if applicable):
2.0/2013-11-15.1
openshift-origin-cartridge-python-1.17.6-2.el6op.noarch

How reproducible:
always

Steps to Reproduce:
1.Install the python cartridge on the node
2.Check the package
[root@broker ~]# rpm -ql openshift-origin-cartridge-python-1.17.6-2.el6op.noarch|grep 3.3
/usr/libexec/openshift/cartridges/python/usr/versions/3.3-community
/usr/libexec/openshift/cartridges/python/usr/versions/3.3-community/bin
/usr/libexec/openshift/cartridges/python/usr/versions/3.3-community/bin/upgrade
/usr/libexec/openshift/cartridges/python/usr/versions/3.3-community/lib
/usr/libexec/openshift/cartridges/python/usr/versions/3.3-community/lib/distribute_setup.py
/usr/libexec/openshift/cartridges/python/usr/versions/3.3-community/lib/distribute_setup.pyc
/usr/libexec/openshift/cartridges/python/usr/versions/3.3-community/lib/distribute_setup.pyo

Actual results:

Expected results:
Should remove the 3.3-community related directory and files in the package.

Additional info:
Comment 2 Jason DeTiberus 2014-01-14 15:18:26 EST
https://github.com/openshift/enterprise-server/pull/200
Comment 3 Gaoyun Pei 2014-01-16 23:35:20 EST
verify this bug with openshift-origin-cartridge-python-1.17.7-1.el6op, the 3.3-community related directory and files in the package has been removed.
Comment 5 errata-xmlrpc 2014-01-28 11:38:58 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0102.html

Note You need to log in before you can comment on or make changes to this bug.