Bug 1032923 - Additional display pop out when restarting service spice-vdagentd in guest
Additional display pop out when restarting service spice-vdagentd in guest
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: spice-gtk (Show other bugs)
6.5
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Jonathon Jongsma
SPICE QE bug list
:
Depends On: 1185434
Blocks: 1009648 1043782
  Show dependency treegraph
 
Reported: 2013-11-21 04:13 EST by tingting zheng
Modified: 2015-07-22 02:30 EDT (History)
10 users (show)

See Also:
Fixed In Version: spice-gtk-0.26-1.el6
Doc Type: Bug Fix
Doc Text:
Cause: race condition when spice-vdagent is started in the guest and the client connects to it Consequence: if the 1st monitor was disabled, it could sometimes be wrongly reenabled after restarting spice-vdagentd Fix: delay sending monitor configuration when an agent connects so that we get a chance to negociate client/agent capabilities first Result: first display no longer gets wrongly reenabled
Story Points: ---
Clone Of:
: 1043782 (view as bug list)
Environment:
Last Closed: 2015-07-22 02:30:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Spice debug log file (223.81 KB, text/plain)
2013-11-21 04:13 EST, tingting zheng
no flags Details

  None (edit)
Description tingting zheng 2013-11-21 04:13:59 EST
Created attachment 827084 [details]
Spice debug log file

Description
Additional display pop out when restarting service spice-vdagentd in guest

Version:
libvirt-0.10.2-29.el6.1.x86_64
virt-viewer-0.5.6-8.el6.x86_64
spice-gtk-python-0.20-11.el6.x86_64
spice-xpi-2.7-24.el6.x86_64
spice-vdagent-0.14.0-2.el6.x86_64
spice-glib-0.20-11.el6.x86_64
spice-gtk-0.20-11.el6.x86_64
spice-server-0.12.4-6.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1.Prepare a spice guest with qxl and spicevmc,install spice-vdagent in guest.
2.Boot the guest,use virt-viewer to launch the guest,disable display 1 and enable other displays,eg display 2.
# virt-viewer $guest
3.Restart service spice-vdagentd in guest.
4.Display 1 will pop out.

Actual results:
As description.

Expected results:
No additional display pop out when restarting service spice-vdagentd in guest.

Additional info:
1.If enable display 1,then restart service spice-vdagentd in guest,no additional display pop out.
2.Disable display 1,enable display 3 or 4,restart service spice-vdagentd in guest,display 1 will pop put.
3.The issue can not be reproduced on rhel7.
Comment 1 Marc-Andre Lureau 2014-06-04 08:47:20 EDT
I can't reproduce with:

virt-viewer-0.6.0-2.el6
spice-vdagent-0.14.0-3.el6_5.x86_64
xorg-x11-drv-qxl-0.1.1-12.el6.x86_64

Please check with more recent vdagent & qxl, or if virt-viewer-0.6.0-2.el6 update fixed the issue. thanks
Comment 2 tingting zheng 2014-06-05 00:57:40 EDT
(In reply to Marc-Andre Lureau from comment #1)
> I can't reproduce with:
> 
> virt-viewer-0.6.0-2.el6
> spice-vdagent-0.14.0-3.el6_5.x86_64
> xorg-x11-drv-qxl-0.1.1-12.el6.x86_64
> 
> Please check with more recent vdagent & qxl, or if virt-viewer-0.6.0-2.el6
> update fixed the issue. thanks

I tested with:
spice-vdagent-0.14.0-3.el6_5.x86_64
xorg-x11-drv-qxl-0.1.1-12.el6.x86_64
virt-viewer-0.6.0-4.el6.x86_64

The bug can still be reproduced.
Comment 3 Marc-Andre Lureau 2014-06-05 04:20:02 EDT
How do you restart vdagent?
Can you provide xrandr before and after the restart?
thanks
Comment 4 tingting zheng 2014-06-06 03:12:02 EDT
(In reply to Marc-Andre Lureau from comment #3)
> How do you restart vdagent?
> Can you provide xrandr before and after the restart?
> thanks

# xrandr
Screen 0: minimum 320 x 200, current 1096 x 828, maximum 8192 x 8192
qxl-0 disconnected
qxl-1 connected 1096x828+0+0 0mm x 0mm
   1024x768       60.0 +
   2560x1600      60.0  
   2000x2000      60.0  
   2560x1440      60.0  
   2048x1536      60.0  
   1920x1440      60.0  
   1920x1200      60.0  
   1920x1080      60.0  
   1600x1200      60.0  
   1680x1050      60.0  
   1400x1050      60.0  
   1600x900       60.0  
   1280x1024      60.0  
   1440x900       60.0  
   1280x960       60.0  
   1366x768       60.0  
   1360x768       60.0  
   1280x800       60.0  
   1152x870       60.0  
   1152x864       60.0  
   1280x768       60.0  
   1280x760       60.0  
   1280x720       60.0  
   1024x600       60.0  
   960x640        60.0  
   832x624        60.0  
   800x600        60.0  
   800x480        60.0  
   640x480        60.0  
   1096x828-1      0.1* 
qxl-2 disconnected
qxl-3 disconnected

# service spice-vdagentd restart
Stopping spice-vdagentd:                                   [  OK  ]
Starting spice-vdagentd:                                   [  OK  ]

# xrandr
Screen 0: minimum 320 x 200, current 1416 x 828, maximum 8192 x 8192
qxl-0 connected 320x200+0+0 0mm x 0mm
   1024x768       60.0 +
   2560x1600      60.0  
   2000x2000      60.0  
   2560x1440      60.0  
   2048x1536      60.0  
   1920x1440      60.0  
   1920x1200      60.0  
   1920x1080      60.0  
   1600x1200      60.0  
   1680x1050      60.0  
   1400x1050      60.0  
   1600x900       60.0  
   1280x1024      60.0  
   1440x900       60.0  
   1280x960       60.0  
   1366x768       60.0  
   1360x768       60.0  
   1280x800       60.0  
   1152x870       60.0  
   1152x864       60.0  
   1280x768       60.0  
   1280x760       60.0  
   1280x720       60.0  
   1024x600       60.0  
   960x640        60.0  
   832x624        60.0  
   800x600        60.0  
   800x480        60.0  
   640x480        60.0  
   320x200-0       0.1* 
qxl-1 connected 1096x828+320+0 0mm x 0mm
   1024x768       60.0 +
   2560x1600      60.0  
   2000x2000      60.0  
   2560x1440      60.0  
   2048x1536      60.0  
   1920x1440      60.0  
   1920x1200      60.0  
   1920x1080      60.0  
   1600x1200      60.0  
   1680x1050      60.0  
   1400x1050      60.0  
   1600x900       60.0  
   1280x1024      60.0  
   1440x900       60.0  
   1280x960       60.0  
   1366x768       60.0  
   1360x768       60.0  
   1280x800       60.0  
   1152x870       60.0  
   1152x864       60.0  
   1280x768       60.0  
   1280x760       60.0  
   1280x720       60.0  
   1024x600       60.0  
   960x640        60.0  
   832x624        60.0  
   800x600        60.0  
   800x480        60.0  
   640x480        60.0  
   1096x828-1      0.1* 
qxl-2 disconnected
qxl-3 disconnected
Comment 5 Fabiano Fidêncio 2014-08-05 10:17:41 EDT
I also cannot reproduce the issue here with latest RHEL6 as guest:
spice-vdagent-0.14.0-3.el6.x86_64
xorg-x11-drv-qxl-0.1.1-12.el6.x86_64

And F20 as host (using upstream virt-viewer)
Comment 6 Jonathon Jongsma 2014-08-27 17:07:45 EDT
I can reproduce quite easily with something like:

  for i in {1..20}; do service spice-vdagentd restart; usleep 500000; done
Comment 7 Jonathon Jongsma 2014-08-27 17:42:05 EDT
see Bug 1043782 comment #4 for description of the cause
Comment 12 errata-xmlrpc 2015-07-22 02:30:49 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1322.html

Note You need to log in before you can comment on or make changes to this bug.