Bug 1032952 - win7-32 guest can not do s4 due to firmware does not support
win7-32 guest can not do s4 due to firmware does not support
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: seabios (Show other bugs)
7.0
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Gerd Hoffmann
Virtualization Bugs
:
Depends On:
Blocks: Virt-S3/S4-7.0
  Show dependency treegraph
 
Reported: 2013-11-21 04:51 EST by Mike Cao
Modified: 2015-11-22 22:37 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-11 05:56:33 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
results of "powercfg -a" (73.95 KB, image/png)
2013-11-21 04:53 EST, Mike Cao
no flags Details

  None (edit)
Description Mike Cao 2013-11-21 04:51:17 EST
Description of problem:


Version-Release number of selected component (if applicable):
3.10.0-50.el7.x86_64
qemu-kvm-rhev-1.5.3-19.el7.x86_64
seabios-1.7.2.2-4.el7.x86_64
seabios-bin-1.7.2.2-4.el7.noarch
virito-win-1.6.7-2

How reproducible:
100%

Steps to Reproduce:
1.Start VM with -global PIIX4_PM.disable_s3=0 -global PIIX_PM.disable_s4=0
CLI: /usr/libexec/qemu-kvm -M pc-i440fx-rhel7.0.0 -cpu SandyBridge -enable-kvm -m 2G -smp 2,cores=2 -name bcao_win-7-32-netkvm -uuid `uuidgen` -rtc base=localtime,clock=host,driftfix=slew -drive file=win7-32.qcow2,if=none,media=disk,werror=stop,rerror=stop,cache=none,format=qcow2,id=drive-disk0 -device ide-drive,drive=drive-disk0,id=disk0 -cdrom en_windows_7_ultimate_with_sp1_x86_dvd_u_677460.iso -fda /usr/share/virtio-win/virtio-win_x86.vfd -netdev tap,vhost=on,queues=4,id=netdev0 -device virtio-net-pci,netdev=netdev0,id=nic1,mq=on,vectors=17,mac=00:52:00:00:51:12 -spice port=5931,disable-ticketing  -vga qxl -monitor stdio -usb -device usb-tablet,id=tablet0 -global PIIX4_PM.disable_s3=0 -global PIIX_PM.disable_s4=0
2.in the guest #powercfg -h on 


Actual results:
It prompts system firmware does not support hibernation

Expected results:
no error prompts ,s4 should be enabled 

Additional info:
s3 works fine
Comment 1 Mike Cao 2013-11-21 04:53:15 EST
Created attachment 827101 [details]
results of "powercfg -a"
Comment 3 Gerd Hoffmann 2013-11-27 07:01:56 EST
Most likely a acpi table issue.
High chance that bug 1034876 (+bug 1034877) fix this.
Michael?
Comment 4 lijin 2013-12-11 02:53:54 EST
I cannot reproduce this bug with the same OS(win7-32).

package info:
    virtio-win-1.6.7-2.el7.noarch
    kernel-3.10.0-53.el7.x86_64
    qemu-kvm-rhev-1.5.3-19.el7.x86_64
    seabios-1.7.2.2-4.el7.x86_64

steps as comment 0

Actual result:
"powercfg -h on" can be executed correctly,and win7-32 guest can do S4 successfully.
Comment 5 Mike Cao 2013-12-11 02:56:20 EST
(In reply to Gerd Hoffmann from comment #3)
> Most likely a acpi table issue.
> High chance that bug 1034876 (+bug 1034877) fix this.
> Michael?

Does it related to specified hosts ?all the guests can not do s4 on my hosts
Comment 6 Gerd Hoffmann 2013-12-11 04:03:11 EST
> Does it related to specified hosts ?all the guests can not do s4 on my hosts

linux guests affected?
windows guests affected?

Unlikely that it is something in the host.
With command line, qemu-kvm and seabios being identical it most likely
something in the guest, such as different guest driver versions.

lijin? Mike?  Can you try work out what the difference is?
Comment 7 lijin 2013-12-11 05:39:06 EST
(In reply to Gerd Hoffmann from comment #6)
> > Does it related to specified hosts ?all the guests can not do s4 on my hosts
> 
> linux guests affected?
> windows guests affected?
> 
> Unlikely that it is something in the host.
> With command line, qemu-kvm and seabios being identical it most likely
> something in the guest, such as different guest driver versions.
> 
> lijin? Mike?  Can you try work out what the difference is?

Seems there is a mistake in comment0's qemu-kvm command:
"-global PIIX_PM.disable_s4=0" should be "-global PIIX4_PM.disable_s4=0".
After change to the right command,guest can do S4.

It's weird that qemu-kvm can boot up even with a mistake command,why qemu-kvm didnot pop up some warning?
Comment 8 Gerd Hoffmann 2013-12-11 05:56:33 EST
> > lijin? Mike?  Can you try work out what the difference is?
> 
> Seems there is a mistake in comment0's qemu-kvm command:
> "-global PIIX_PM.disable_s4=0" should be "-global PIIX4_PM.disable_s4=0".
> After change to the right command,guest can do S4.

Ok, good.  So this isn't a bug.

> It's weird that qemu-kvm can boot up even with a mistake command,why
> qemu-kvm didnot pop up some warning?

-global settings simply go into global device configuration, basically same space where the compat properties for older machine types are living too.  It is a perfectly valid thing for for compat properties to exist for devices not actually present in the virtual machine, or even devices not supported by rhel7 qemu-kvm binary.  Which makes it difficult to catch that kind of error.

Note You need to log in before you can comment on or make changes to this bug.