Bug 1032971 - Can not keep right resolution after change back to graphics mode and send-key ctrl+alt+backspace
Can not keep right resolution after change back to graphics mode and send-key...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virt-viewer (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Virt Viewer Maint
Virtualization Bugs
:
: 1033447 1074614 (view as bug list)
Depends On: 1021841 1033447
Blocks: 1009648
  Show dependency treegraph
 
Reported: 2013-11-21 05:32 EST by CongDong
Modified: 2015-07-16 11:09 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
When the agent terminated unexpectedly or was disconnected and reconnected again, virt-viewer did not update the information about windows geometry and the guest resolution was not restored accordingly. With this update, the function responsible for updating the displays geometry is called, thus fixing the bug.
Story Points: ---
Clone Of: 1021841
Environment:
Last Closed: 2015-03-05 08:38:45 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
virt-viewer and spice log (226.99 KB, text/x-log)
2013-11-21 05:32 EST, CongDong
no flags Details

  None (edit)
Description CongDong 2013-11-21 05:32:58 EST
Created attachment 827119 [details]
virt-viewer and spice log

+++ This bug was initially created as a clone of Bug #1021841 +++
Can reproduce this on rhel7, 
# rpm -qa virt-viewer spice*
spice-glib-0.20-6.el7.x86_64
spice-server-0.12.4-3.el7.x86_64
spice-gtk3-0.20-6.el7.x86_64
virt-viewer-0.5.7-2.el7.x86_64
spice-xpi-2.8-4.el7.x86_64
spice-vdagent-0.14.0-5.el7.x86_64

On rhel7, the resolution is not right after step 3.

Description of problem:
The display got wrong resolution after I change the guest back to the graphics mode and send-key ctrl+alt+backspace

Version-Release number of selected component (if applicable):
# rpm -qa virt-viewer spice*
spice-gtk-0.20-9.el6.x86_64
virt-viewer-0.5.6-8.el6.x86_64
spice-glib-0.20-9.el6.x86_64
spice-server-0.12.4-6.el6.x86_64
spice-vdagent-0.14.0-2.el6.x86_64
spice-gtk-python-0.20-9.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1.Have a guest with graphics desktop
# virt-viewer rhel6.4 -f
2.Open the send-key menu, and send ctrl+alt+f1, change the guest to the text mode
  Send-key -> ctrl+alt+f1
3.Change the guest back to the graphics mode.
  Send-key -> ctrl+alt+f7
4. Send-key -> ctrl+alt+backspace

Actual results:
After step4, the guest change back to graphics mode, but the resolution is not same with the physical monitor.

Expected results:
The display should keep the right resolution.

Additional info:
Comment 2 zhengqin 2013-11-22 01:36:39 EST
*** Bug 1033447 has been marked as a duplicate of this bug. ***
Comment 3 Marc-Andre Lureau 2013-12-12 05:51:51 EST
waiting for dep bug to be resolved.
Comment 4 CongDong 2013-12-17 00:41:30 EST
Can reproduce this with :
# rpm -qa virt-viewer
virt-viewer-0.5.7-3.el7.x86_64

Steps:
1.Have a guest with graphics desktop
# virt-viewer rhel6.4 -f
2.Open the send-key menu, and send ctrl+alt+f1, change the guest to the text mode
  Send-key -> ctrl+alt+f1
3.Change the guest back to the graphics mode.
  Send-key -> ctrl+alt+f7
4. Send-key -> ctrl+alt+backspace
5. Repeat step3 and step4 5 times

results:
After step5, the guest change back to graphics mode, but the resolution is not same with the physical monitor.
And the font looks very small.
Comment 5 Marc-Andre Lureau 2013-12-17 05:12:38 EST
imho, it should be closed as dup of 1021841
Comment 6 RHEL Product and Program Management 2014-03-24 01:50:27 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 7 David Jaša 2014-07-03 10:17:08 EDT
*** Bug 1074614 has been marked as a duplicate of this bug. ***
Comment 8 Fabiano Fidêncio 2014-08-18 07:09:06 EDT
Change the status of the bug to POST, according to https://bugzilla.redhat.com/show_bug.cgi?id=1021841#c9
Comment 9 Christophe Fergeau 2014-09-19 09:54:57 EDT
Reassigning as per comment in the other bug:

« Fabiano Fidêncio 2014-09-19 09:29:46 EDT

(In reply to Christophe Fergeau from comment #10)
> The patch you mentioned (
> https://www.redhat.com/archives/virt-tools-list/2014-August/msg00064.html )
> is for virt-viewer, and since the 2nd scenario is not going to be fixed,
> this bug should be reassigned to virt-viewer, right?

Yes, you're right. Just reassigned. »
Comment 11 CongDong 2014-10-09 21:54:09 EDT
I can reproduce with: virt-viewer-0.6.0-6.el7.x86_64

VERIFY with virt-viewer-0.6.0-7.el7.x86_64

Steps:
1.Have a guest with graphics desktop
# virt-viewer rhel6.4 -f
2.Open the send-key menu, and send ctrl+alt+f1, change the guest to the text mode
  Send-key -> ctrl+alt+f1
3.Change the guest back to the graphics mode.
  Send-key -> ctrl+alt+f7
4. Send-key -> ctrl+alt+backspace

Result:
The resolution is not change.

As the result, set VERIFIED.
Comment 13 errata-xmlrpc 2015-03-05 08:38:45 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0295.html

Note You need to log in before you can comment on or make changes to this bug.