Bug 1032972 - [engine-backend] engine sends CreateStoragePool command to vdsm, although it's already connected to another pool
[engine-backend] engine sends CreateStoragePool command to vdsm, although it'...
Status: CLOSED DUPLICATE of bug 1023145
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.3.0
x86_64 Unspecified
unspecified Severity high
: ---
: 3.4.0
Assigned To: nobody nobody
storage
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-21 05:34 EST by Elad
Modified: 2016-02-10 12:08 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-21 08:06:44 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
logs (2.49 MB, application/x-gzip)
2013-11-21 05:34 EST, Elad
no flags Details

  None (edit)
Description Elad 2013-11-21 05:34:46 EST
Created attachment 827120 [details]
logs

Description of problem:
Engine sends CreateStoragePool command to vdsm, although the host is already connected to another pool.

Version-Release number of selected component (if applicable):
is24
rhevm-3.3.0-0.35.beta1.el6ev.noarch
vdsm-4.13.0-0.9.beta1.el6ev.x86_64


How reproducible:
100%

Steps to Reproduce:
1. Have host with tasks unknown at the engine (can be achieved by stopping vdsm service while creating live snapshot with memory saved. It will cause to the deleteImage task to stay running, as reported on:  https://bugzilla.redhat.com/show_bug.cgi?id=1019394)
2. move the host to maintenance
3. create a new DC and cluster
4. attach the host to the new cluster and activate it
5. create a storage domain on the new DC


Actual results:
Although vdsm has running task and it connected to another pool, it succeeds in creating a new pool:

engine:

2013-11-21 12:25:13,657 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.CreateStoragePoolVDSCommand] (ajp-/127.0.0.1:8702-9) [590c4b89] START, CreateStoragePoolVDSCommand(HostName = nott-vds1, HostId = 40bd7695-b
0a8-487c-91ef-a4190fd86b77, storagePoolId=0b80cd15-4db6-4924-8fb2-096ddebcfd95, storageType=ISCSI, storagePoolName=iscsi4, masterDomainId=1be37dd3-2d0a-4f88-b362-7e488988ea35, domainsIdList=[1be37dd3-2d0a-4f88-b36
2-7e488988ea35], masterVersion=1), log id: 648a4a91
2013-11-21 12:25:46,341 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.CreateStoragePoolVDSCommand] (ajp-/127.0.0.1:8702-9) [590c4b89] FINISH, CreateStoragePoolVDSCommand, log id: 648a4a91


vdsm:

Thread-2324::INFO::2013-11-21 12:25:16,072::logUtils::44::dispatcher::(wrapper) Run and protect: createStoragePool(poolType=None, spUUID='0b80cd15-4db6-4924-8fb2-096ddebcfd95', poolName='iscsi4', masterDom='1be37d
d3-2d0a-4f88-b362-7e488988ea35', domList=['1be37dd3-2d0a-4f88-b362-7e488988ea35'], masterVersion=1, lockPolicy=None, lockRenewalIntervalSec=5, leaseTimeSec=61, ioOpTimeoutSec=11, leaseRetries=3, options=None)

ActivateStorageDomainVDS fails:

2013-11-21 12:25:47,015 ERROR [org.ovirt.engine.core.vdsbroker.irsbroker.IrsBrokerCommand] (ajp-/127.0.0.1:8702-9) [6ea2390] IrsBroker::Failed::ActivateStorageDomainVDS due to: IRSNonOperationalException: IRSGener
icException: IRSErrorException: IRSNonOperationalException: Could not connect host to Data Center(Storage issue)


2013-11-21 12:25:47,017 ERROR [org.ovirt.engine.core.bll.storage.ActivateStorageDomainCommand] (ajp-/127.0.0.1:8702-9) [6ea2390] Command org.ovirt.engine.core.bll.storage.ActivateStorageDomainCommand throw Vdc Bll exception. With error message VdcBLLException: org.ovirt.engine.core.vdsbroker.irsbroker.IRSNonOperationalException: IRSGenericException: IRSErrorException: IRSNonOperationalException: Could not connect host to Data Center(Storage issue) (Failed with error ENGINE and code 5001)


Expected results:
It should not be possible to create a new pool using a host that is already connected to another one.

Additional info: logs
Comment 1 Ayal Baron 2013-11-21 08:06:44 EST

*** This bug has been marked as a duplicate of bug 1023145 ***

Note You need to log in before you can comment on or make changes to this bug.