Bug 1032978 - When plugging in an external screen, brightness defaults to the lowest possible setting
When plugging in an external screen, brightness defaults to the lowest possib...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
:
: 1090860 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-21 05:39 EST by Elad Alfassa
Modified: 2015-01-26 08:03 EST (History)
14 users (show)

See Also:
Fixed In Version: xorg-x11-drv-intel-2.21.15-7.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-19 19:00:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
journalctl concerning thinkpad_acpi driver (1.29 KB, text/plain)
2014-04-03 15:30 EDT, Lucile Quirion
no flags Details
restart Xorg, plug HDMI, wait for appr. 30 sec., suspend/resume (close/open lid) (42.33 KB, text/x-log)
2014-06-03 10:53 EDT, Lucile Quirion
no flags Details
Xorg.0.log.2 (42.22 KB, application/x-troff-man)
2014-06-05 10:37 EDT, Lucile Quirion
no flags Details
Xorg.0.log.3 (42.30 KB, application/x-troff-man)
2014-06-06 14:02 EDT, Lucile Quirion
no flags Details

  None (edit)
Description Elad Alfassa 2013-11-21 05:39:48 EST
When plugging in an external screen, brightness of the laptop screen defaults to the lowest possible setting, which on Lenovo laptops means backlight turns off completely.

This shouldn't happen.
Comment 1 Nathanel Titane 2013-11-25 01:17:16 EST
+1 for me using an Asus X75VD with HDMI out. When closing the lid and eventually opening it to resume activity, the system wakes adequately but does not reinstate previous brightness setting and defaults it to 0 on laptop display (no image whatsoever.)

Linux Mercury 3.11.8-300.fc20.x86_64 #1 SMP Wed Nov 13 16:34:27 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

Fedora 20 x86_64
Comment 2 Jonathan Kamens 2013-12-19 17:31:12 EST
Seeing this with ThinkPad T420i. It wasn't happening in Fedora 19, just started yesterday when I upgraded to Fedora 20.
Comment 3 Justin M. Forbes 2014-02-24 09:03:20 EST
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 20 kernel bugs.

Fedora 20 has now been rebased to 3.13.4-200.fc20.  Please test this kernel update and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you experience different issues, please open a new bug report for those.
Comment 4 Elad Alfassa 2014-02-24 09:05:19 EST
Still a problem even with latest kernel.
Comment 5 Lucile Quirion 2014-04-03 15:30:09 EDT
Created attachment 882405 [details]
journalctl concerning thinkpad_acpi driver

+1 for me using an Thinkpad Twist (S230u)

When the external screen is plugged, brightness of the laptop screen defaults to 0.
Booting with the external screen plugged in causes the same problem.
Closing the lid and opening it again defaults laptop screen brightness to 0.

$ uname -sr
Linux 3.13.7-200.fc20.x86_64

$ cat /etc/fedora-release 
Fedora release 20 (Heisenbug)

$ journalctl -b | grep brightness
avr 03 09:37:09 localhost.localdomain kernel: thinkpad_acpi: Unsupported brightness interface, please contact ibm-acpi-devel@lists.sourceforge.net
avr 03 09:37:09 localhost.localdomain kernel: thinkpad_acpi: This ThinkPad has standard ACPI backlight brightness control, supported by the ACPI video driver
avr 03 09:37:09 localhost.localdomain kernel: thinkpad_acpi: Disabling thinkpad-acpi brightness events by default...

Following some discussions in this mailing-list it seems the file incriminated is linux/drivers/gpu/drm/i915/intel_panel.c
Several commits have been applied to this file.

Any help to build and test the v3.14 i915 driver would be appreciated.
Comment 6 Lucile Quirion 2014-04-04 17:17:45 EDT
I traced access/write to /sys/class/backlight/intel_backlight/brightness with systemtap and plugged the external screen (HDMI). 

Xorg is the process accessing the file to write 0.

I have the following drivers installed:
$ rpm -qa | grep intel
xorg-x11-drv-intel-2.21.15-5.fc20.x86_64

I tested with default config (UXA) then SNA and evertime Xorg set brightness to 0.

Good luck
Comment 7 Elad Alfassa 2014-04-04 17:20:04 EDT
Moving this bug to xorg-x11-drv-intel
Comment 8 Nicolas Dufresne 2014-05-26 10:27:18 EDT
Same here, Thinkpad X230. At boot the backlight is set to 0, and after login same thing.
Comment 9 Hans de Goede 2014-06-02 09:34:26 EDT
Hi All,

I've just done a scratch build of the Fedora-20 intel driver with some debugging added to try and see
where the 0 it is allegedly writing to brightness is coming from.  You can find it here:
http://koji.fedoraproject.org/koji/taskinfo?taskID=6917469

Please install this, then do the following to kill your session (to restart X) :

sudo killall Xorg

Then plug in the hdmi cable, wait 30 seconds, do a suspend / resume, and collect the /var/log/Xorg.0.log file and attach it here.

Thanks,

Hans
Comment 10 Hans de Goede 2014-06-02 14:35:56 EDT
Also can you please try the latest 3.15 kernel? With some luck this has already been fixed, you cfan find the latest 3.15 kernel build for Fedora here:
http://koji.fedoraproject.org/koji/buildinfo?buildID=520926

Download the kernel-3.15...rpm for your architecture and then install it using:

sudo rpm -ivh kernel-3.15...rpm

Note when installing kernels it is important to rpm -i so that you keep your current kernel as a backup.
Comment 11 Lucile Quirion 2014-06-03 10:53:10 EDT
Created attachment 901818 [details]
restart Xorg, plug HDMI, wait for appr. 30 sec., suspend/resume (close/open lid)

Hi,

The latest 3.15 kernel does not resolve the problem.

The latest Intel drivers: xorg-x11-drv-intel-2.99.910-20.intel20141.x86_64 do not resolve the problem. (https://download.01.org/gfx/fedora/20/x86_64/)

However I did not had this problem with Ubuntu Saucy (2.99.904).

I did the manipulation with xorg-x11-drv-intel-2.21.15-6.fc20.hdg1032978.x86_64 installed (see attachment), and kernel 3.14:
restart Xorg (brightness ok)
plug HDMI (laptop brightness nok, external screen ok)
suspend/resume (laptop brightness nok, external screen ok)
Comment 12 Elad Alfassa 2014-06-05 04:52:37 EDT
Hi Hans.

I followed your instructions, but the log file is not being written to for some reason (and hasn't been written to in a while)

However, I did manage to extract some useful info from the systemd journal.
After pluging in the external screen, it was not detected. I ran xrandr in the terminal (twice. first time it did nothing, second time it detected the screen) and then got these in the log:

Jun 05 11:42:06 rincewind gdm-Xorg-:0[28225]: (II) intel(0): XRANDR backlight property get, active_level 1054, DPMS mode 0, returning 1054
Jun 05 11:42:06 rincewind gdm-Xorg-:0[28225]: (II) intel(0): XRANDR backlight property set to 1054, DPMS mode 0
Jun 05 11:42:06 rincewind gdm-Xorg-:0[28225]: (II) intel(0): resizing framebuffer to 3286x1080
Jun 05 11:42:06 rincewind gdm-Xorg-:0[28225]: (II) intel(0): switch to mode 1366x768@59.8 on pipe 0 using LVDS1, position (0, 0), rotation normal
Jun 05 11:42:06 rincewind gdm-Xorg-:0[28225]: (II) intel(0): switch to mode 1920x1080@60.0 on pipe 0 using HDMI2, position (1366, 0), rotation normal
Jun 05 11:42:07 rincewind gdm-Xorg-:0[28225]: (II) intel(0): DPMS off mode 3, saved backlight level 0
Jun 05 11:42:07 rincewind gdm-Xorg-:0[28225]: (II) intel(0): switch to mode 1366x768@59.8 on pipe 1 using LVDS1, position (0, 0), rotation normal
Jun 05 11:42:07 rincewind gdm-Xorg-:0[28225]: (II) intel(0): DPMS on mode 0, setting backlight to 0
Jun 05 11:42:07 rincewind gdm-Xorg-:0[28225]: (II) intel(0): XRANDR backlight property get, active_level 0, DPMS mode 0, returning 0
Jun 05 11:42:07 rincewind gdm-Xorg-:0[28225]: (II) intel(0): XRANDR backlight property set to 0, DPMS mode 0
Jun 05 11:42:07 rincewind gdm-Xorg-:0[28225]: (II) intel(0): XRANDR backlight property get, active_level 0, DPMS mode 0, returning 0
Jun 05 11:42:07 rincewind gdm-Xorg-:0[28225]: (II) intel(0): XRANDR backlight property set to 0, DPMS mode 0
Jun 05 11:42:07 rincewind gdm-Xorg-:0[28225]: (II) intel(0): XRANDR backlight property get, active_level 0, DPMS mode 0, returning 0
Jun 05 11:42:07 rincewind gdm-Xorg-:0[28225]: (II) intel(0): XRANDR backlight property set to 0, DPMS mode 0
Comment 13 Hans de Goede 2014-06-05 08:54:38 EDT
Hi,

I think I know what is causing this, here is a new (scratch) xorg-x11-drv-intel package, which should fix this:

http://koji.fedoraproject.org/koji/taskinfo?taskID=6926499

Please give this a try without using any special kernel commandline options, and let me know if it fixes things. Please also collect and attach Xorg.0.log again.

Thanks & Regards,

Hans
Comment 14 Lucile Quirion 2014-06-05 10:37:56 EDT
Created attachment 902564 [details]
Xorg.0.log.2

Hi Hans,

The driver v2 worked partially :
restart xorg (laptop brightness ok)
plug HDMI (laptop + external screen ok)
suspend/resume (laptop nok, external screen ok)

I've attached the resulting Xorg.0.log 

Thanks
Comment 15 Hans de Goede 2014-06-06 11:03:33 EDT
Hi,

(In reply to Lucile Quirion from comment #14)
> Created attachment 902564 [details]
> Xorg.0.log.2
> 
> Hi Hans,
> 
> The driver v2 worked partially :
> restart xorg (laptop brightness ok)
> plug HDMI (laptop + external screen ok)
> suspend/resume (laptop nok, external screen ok)
> 
> I've attached the resulting Xorg.0.log 

Thanks, I've done a new build with one more fix which should hopefully fix the last case your seeing where the screen stays black:

http://koji.fedoraproject.org/koji/taskinfo?taskID=6929186

Please give this a try without using any special kernel commandline options, and let me know if it fixes things. Please also collect and attach Xorg.0.log again.

Thanks & Regards,

Hans
Comment 16 Lucile Quirion 2014-06-06 14:02:35 EDT
Created attachment 902997 [details]
Xorg.0.log.3

Hi,

The last version of the driver fixes things for me.

Xorg.0.log.3 is the log for the following test: restart Xorg, plug HDMI, wait 30s, suspend/resume with the driver v3.

Thank you very much.
Comment 17 Elad Alfassa 2014-06-08 06:23:24 EDT
Hi,
I can confirm this build fixes the problem for me too.

I think it should be pushed to F20 updates now :)
Comment 18 Hans de Goede 2014-06-11 06:17:13 EDT
*** Bug 1090860 has been marked as a duplicate of this bug. ***
Comment 19 Hans de Goede 2014-06-13 09:20:21 EDT
Hi All,

Upstream has come up with a fix which in some ways is quite different, which I've backported to the intel driver version in F-20. Can you please give this build a try:

http://koji.fedoraproject.org/koji/taskinfo?taskID=7042962

Once I've confirm that the (backported) upstream commit also fixes the backlight issues people have reported, then I'll do an official build with these fixes in, and we can finally close this bug.

Thanks,

Hans
Comment 20 Jiri Eischmann 2014-06-16 08:09:55 EDT
Yes, I can confirm that the backlight doesn't default to 0 any more. Now it defaults to 100% which is not a complete fix, but definitely better than a blackscreen.
Comment 21 Fedora Update System 2014-06-18 09:48:41 EDT
xorg-x11-drv-intel-2.21.15-7.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/xorg-x11-drv-intel-2.21.15-7.fc20
Comment 22 Fedora Update System 2014-06-18 18:21:48 EDT
Package xorg-x11-drv-intel-2.21.15-7.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing xorg-x11-drv-intel-2.21.15-7.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-7476/xorg-x11-drv-intel-2.21.15-7.fc20
then log in and leave karma (feedback).
Comment 23 Fedora Update System 2014-06-19 19:00:03 EDT
xorg-x11-drv-intel-2.21.15-7.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.