This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1032982 - Correct gear cost info should display when adding cartridge using url for a scalable app
Correct gear cost info should display when adding cartridge using url for a s...
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Website (Show other bugs)
2.0.0
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Luke Meyer
libra bugs
:
Depends On: 1031916
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-21 05:51 EST by Johnny Liu
Modified: 2017-03-08 12 EST (History)
7 users (show)

See Also:
Fixed In Version: rubygem-openshift-origin-console-1.17.6.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1031916
Environment:
Last Closed: 2014-01-13 09:54:32 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Johnny Liu 2013-11-21 05:51:30 EST
+++ This bug was initially created as a clone of Bug #1031916 +++

Description of problem:
Go to web console and create a scalable app. Add community cartridge using url for the app, then find the gear cost will show "+0-1", and "This will add 0 gears to your account" when mouse acrossing gear info. Since we may not know what kind of cartridge will be added, so it's not proper to show "This will add 0 gears to your account".

Version-Release number of selected component (if applicable):
devenv_4047

How reproducible:
Always

Steps to Reproduce:
1. Go to web console and create a scalable app
2. Add community cartridge using url and check gear cost info
3. 

Actual results:
It warns with "This will add 0 gears to your account" when mouse acrossing.

Expected results:
The warning should be set to "0-1 gears to your account".

Additional info:

--- Additional comment from Jordan Liggitt on 2013-11-19 15:07:56 EST ---

Will merge in https://github.com/openshift/origin-server/pull/4199

--- Additional comment from openshift-github-bot on 2013-11-19 18:12:36 EST ---

Commit pushed to master at https://github.com/openshift/origin-server

https://github.com/openshift/origin-server/commit/a61aaad56b226d0deb1d71b9d81844cb223acbb7
Fix bug 1031916: Show correct gear cost tooltip

--- Additional comment from Tian Feng on 2013-11-19 21:25:04 EST ---

Test on devenv_4051. When adding community cartridge using url, it will warn user with "This will add between 0 and 1 gear to your account." So verify this bug, thanks!
Comment 2 Luke Meyer 2013-12-10 10:16:28 EST
https://github.com/openshift/enterprise-server/pull/162

commit c64210c206c2d3e68cd03528c88988618f8f3c1f
Author:     liggitt <jliggitt@redhat.com>
AuthorDate: Tue Nov 19 09:40:46 2013 -0500
Commit:     Luke Meyer <lmeyer@redhat.com>
CommitDate: Thu Dec 5 17:49:08 2013 -0500

    Fix bug 1031916: Show correct gear cost tooltip #cherrypick

    OSE bug 1032982
    https://bugzilla.redhat.com/show_bug.cgi?id=1032982
    cp'ed a61aaad56b226d0deb1d71b9d81844cb223acbb7
Comment 3 Luke Meyer 2013-12-12 17:27:42 EST
rubygem-openshift-origin-console-1.17.6.1 actually built now, should be in the next 2.0 puddle. On brew at  http://download.devel.redhat.com/brewroot/packages/rubygem-openshift-origin-console/1.17.6.1/1.el6op/noarch/rubygem-openshift-origin-console-1.17.6.1-1.el6op.noarch.rpm
Comment 5 Tian Feng 2013-12-15 22:29:24 EST
Test on puddle [2.0/2013-10-09.3].
Create a scalable app and add cartridge using community url. When mouse crossing over adding gear info, it shows "This will add between 0 and 1 gear to your account." So verify this bug, thanks!
Comment 7 errata-xmlrpc 2014-01-13 09:54:32 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0020.html

Note You need to log in before you can comment on or make changes to this bug.