Bug 1033003 - [RHEVM] cannot upgrade RHEVM 3.2 to RHEVM 3.3 because of rhevm-tools-3.3.0-0.22.master.el6ev.noarch Requires: rhevm-notification-service = 3.2.3-0.43.el6ev
[RHEVM] cannot upgrade RHEVM 3.2 to RHEVM 3.3 because of rhevm-tools-3.3.0-0....
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-setup (Show other bugs)
3.3.0
x86_64 Linux
medium Severity medium
: ---
: 3.2.5
Assigned To: Sandro Bonazzola
Jiri Belka
integration
: Triaged, ZStream
Depends On: 1011087
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-21 06:38 EST by rhev-integ
Modified: 2013-12-18 09:10 EST (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Due to package renaming in v3.3, upgrading system by just running 'yum update' failed dependency resolution. Also redhat-support-plugin-rhev was breaking dependencies resolution with the hypervisor version locked. Adding the non existent package rhevm-tools-3.2.z and redhat-support-plugin-rhev to version lock allows yum to resolve correctly the dependencies.
Story Points: ---
Clone Of: 1011087
Environment:
Last Closed: 2013-12-18 09:10:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Sandro Bonazzola 2013-11-21 06:41:47 EST
Removing TestOnly, on 3.2.5 the patch discussed in bug #1011087 is needed.
Comment 2 Sandro Bonazzola 2013-11-22 06:46:26 EST
It seems that dependencies have been changed between 3.2.3 and 3.2.4.
Now, after having fixed the rhevm-tools dependency I've the following error:

Error: Package: redhat-support-plugin-rhev-3.3.0-11.el6ev.noarch (qa-latest)
           Requires: rhevm >= 3.3.0
           Installed: rhevm-3.2.4-0.44.el6ev.noarch (@qa-latestsf)
               rhevm = 3.2.4-0.44.el6ev
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

# rpm -qv redhat-support-plugin-rhev rhevm
redhat-support-plugin-rhev-3.2.1-2.el6ev.noarch
rhevm-3.2.4-0.44.el6ev.noarch

I'll try to fix also this dependency resolution using the locklist.
However, redhat-support-plugin-rhev doesn't follow other packages naming convention (doesn't contain rhevm) so the change is a bit bigger.
Comment 5 Charlie 2013-11-27 19:42:35 EST
This bug is currently attached to errata RHBA-2013:16431. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to 
minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes 

Thanks in advance.
Comment 6 Jiri Belka 2013-11-29 09:59:55 EST
ok, rhevm-3.2.5-0.48.el6ev.noarch -> rhevm-3.3.0-0.37.beta1.el6ev.noarch

Workaround for broken smooth upgrade because of redhat-support-plugin-rhev.

-%-
...snip...
[ INFO  ] Stage: Package installation
[ ERROR ] Yum [u'redhat-support-plugin-rhev-3.2.1-3.el6ev.noarch requires rhevm < 3.3']
[ ERROR ] Failed to execute stage 'Package installation': [u'redhat-support-plugin-rhev-3.2.1-3.el6ev.noarch requires rhevm < 3.3']
[ INFO  ] Yum Performing yum transaction rollback
[ INFO  ] Stage: Clean up
          Log file is located at /var/log/ovirt-engine/setup/ovirt-engine-setup-20131129155515.log
[ INFO  ] Stage: Pre-termination
[ INFO  ] Stage: Termination
[ ERROR ] Execution of upgrade failed
# rpm --nodeps -Uhv $url/redhat-support-plugin-rhev-3.3.0-12.el6ev.noarch.rpm
Retrieving http://10.34.63.204/repo-tlv-builds/latest_is/redhat-support-plugin-rhev-3.3.0-12.el6ev.noarch.rpm
Preparing...                ########################################### [100%]
   1:redhat-support-plugin-r########################################### [100%]
# engine-setup
-%-
Comment 8 errata-xmlrpc 2013-12-18 09:10:51 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1831.html

Note You need to log in before you can comment on or make changes to this bug.