Bug 1033011 - katello-configure --proxy-url accepts invalid input
katello-configure --proxy-url accepts invalid input
Status: CLOSED WONTFIX
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Hammer (Show other bugs)
6.0.2
Unspecified Unspecified
unspecified Severity medium (vote)
: Unspecified
: --
Assigned To: Mike McCune
Katello QA List
: Triaged
Depends On: 1025890 1116898
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-21 07:16 EST by Justin Sherrill
Modified: 2017-05-23 06:36 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-13 08:46:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Justin Sherrill 2013-11-21 07:16:33 EST
Description of problem:

if you pass only a fqdn to --proxy-url as part of the installation, everything will go fine but syncing will be broken.  


Version-Release number of selected component (if applicable):
Satellite mdp2

How reproducible:
Always

Steps to Reproduce:
1.  Install katello and only specify an fqdn/hostname to --proxy-url
2.  import a manifest, enable a product & repo, and try to sync one

Actual results:
Failure

Expected results:
Should not be able to pass in just the fqdn/hostnanme to --proxy-url, it should require a proper protocol in the url. (i.e. http://hostname.com/)

Additional info:

Error in /var/log/pulp/nectar.log:
TypeError: sequence item 0: expected string, NoneType found
2013-11-20 20:30:50,497 nectar.downloaders.threaded:ERROR: Unhandled Exception in Worker Thread [140719895340800]
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/nectar/downloaders/threaded.py", line 93, in worker
    session = build_session(self.config)
  File "/usr/lib/python2.6/site-packages/nectar/downloaders/threaded.py", line 282, in build_session
    _add_proxy(session, config)
  File "/usr/lib/python2.6/site-packages/nectar/downloaders/threaded.py", line 312, in _add_proxy
    url = ':'.join((host, str(config.proxy_port)))
Comment 1 RHEL Product and Program Management 2013-11-21 07:42:26 EST
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.
Comment 6 Corey Welton 2014-06-03 15:24:59 EDT
bouncing to 6.0.4
Comment 7 Bryan Kearney 2015-10-13 08:46:53 EDT
katello-configure is no longer shipped, and the new installer has undergone substantial testing on proxies. Closing this out.

Note You need to log in before you can comment on or make changes to this bug.