Bug 1033032 - Aborted in schedule_queued_recipe: 'NoneType' object has no attribute 'id'
Aborted in schedule_queued_recipe: 'NoneType' object has no attribute 'id'
Status: CLOSED CURRENTRELEASE
Product: Beaker
Classification: Community
Component: general (Show other bugs)
0.14
Unspecified Unspecified
unspecified Severity high (vote)
: 0.14.4
: ---
Assigned To: Nick Coghlan
tools-bugs
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-21 07:58 EST by Robin Hack
Modified: 2018-02-05 19:41 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-19 00:09:17 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 2 Dan Callaghan 2013-11-21 16:39:30 EST
Complete stack trace:

Nov 21 11:52:47 beaker-02 beakerd[29765]: bkr.server.tools.beakerd ERROR Error in schedule_queued_recipe(1141847)
Nov 21 11:52:47 beaker-02 beakerd[29765]:  Traceback (most recent call last):
Nov 21 11:52:47 beaker-02 beakerd[29765]:    File "/usr/lib/python2.6/site-packages/bkr/server/tools/beakerd.py", line 445, in schedule_queued_recipes
Nov 21 11:52:47 beaker-02 beakerd[29765]:      schedule_queued_recipe(recipe_id, guest_recipe_id)
Nov 21 11:52:47 beaker-02 beakerd[29765]:    File "/usr/lib/python2.6/site-packages/bkr/server/tools/beakerd.py", line 568, in schedule_queued_recipe
Nov 21 11:52:47 beaker-02 beakerd[29765]:      if not System.free(user).filter(System.id == system.id).first():
Nov 21 11:52:47 beaker-02 beakerd[29765]:  AttributeError: 'NoneType' object has no attribute 'id'
Comment 3 Dan Callaghan 2013-11-21 16:43:20 EST
This is a regression in 0.14.3 due to the fix for bug 967479.
Comment 5 Nick Coghlan 2013-11-22 01:57:07 EST
On Gerrit: http://gerrit.beaker-project.org/2536

Note You need to log in before you can comment on or make changes to this bug.