Bug 1033044 - [horizon] only meters associated with the first instance reported appear in Metric dropdown list
[horizon] only meters associated with the first instance reported appear in M...
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-django-horizon (Show other bugs)
4.0
Unspecified Unspecified
medium Severity medium
: rc
: 4.0
Assigned To: Eoghan Glynn
Nir Magnezi
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-21 08:17 EST by Eoghan Glynn
Modified: 2013-12-19 19:37 EST (History)
8 users (show)

See Also:
Fixed In Version: python-django-horizon-2013.2-6.el6ost
Doc Type: Bug Fix
Doc Text:
Previously, the Metric drop-down list in the Stats tab of the Horizon admin/Resource Usage panel only listed type-specific meters of the first instance reported by the nova-api service. As a result, when instances of with different flavors are launched, Horizon only displayed type-specific meters from only one of those instances. With this release, Horizon now retrieves all type-specific meters from the Metering API service before rendering the Metric drop-down list. This ensures that all concrete 'instance.<type>' meters that exist in the Metering store are visible via the Horizon dashboard.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-19 19:37:42 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1243298 None None None Never
OpenStack gerrit 53166 None None None Never
OpenStack gerrit 57919 None None None Never

  None (edit)
Description Eoghan Glynn 2013-11-21 08:17:23 EST
Description of problem:

The Compute (Nova) meters list is generally incomplete in the Metric dropdown on the Stats tab of the admin/Resource Usage panel.

The content of this dropdown list also changes from time to time.

This is because the list is populated from the meter links in the *first* resource reported by the ceilometer API with availability zone metadata (i.e. indicating a nova instance).

However, the set of meters associated with instances is not uniform in ceilometer (i.e. a certain meter gathered for one resource may not necessarily be gathered for another).

Also the content of this list changes from time to time, depending on the order of sample acquisition (as a different instance, with a different set of associated meters, may be at the head of the resources list reported by the ceilometer API).

For example, once instances of different flavors have been spun up in an openstack deployment, the Metric list will not contain all the possible compute meters, nor will it even always be incorrect in the same way. Only the 'instance:<flavor>' meter relating to the first instance appears in the dropdown, and the identity of this first instance may change over time.

So at any given point in time, only a subset of the compute meters are accessible via the dashboard.


Version-Release number of selected component (if applicable):

RHOS 4.0 beta


How reproducible:

100%


Steps to Reproduce:
1. Spin two instances with different flavor (say m1.tiny and m1.micro)

2. Open the admin/Resource Usage panel

3. Note that only one 'instance:<flavor>' meter is reported in the Metric downdrop box


Actual results:

Only one 'instance:<flavor>' meter is reported in the Metric downdrop box.


Expected results:

A 'instance:<flavor>' meter for each existing instance type should be reported in the Metric downdrop box.
Comment 1 Eoghan Glynn 2013-11-21 08:18:52 EST
Fix proposed upsteam:

  https://review.openstack.org/53166
Comment 3 Eoghan Glynn 2013-11-27 07:28:00 EST
Fix proposed to master upstream:

  https://review.openstack.org/53166

and has landed:

  https://github.com/openstack/horizon/commit/264a595c
Comment 4 Eoghan Glynn 2013-11-27 07:28:53 EST
Fix proposed to stable/havana upstream:

  https://review.openstack.org/57919
Comment 5 Eoghan Glynn 2013-11-28 06:39:55 EST
Landed on stable/master upstream:

   http://github.com/openstack/horizon/commit/ce47e8a0
Comment 6 Eoghan Glynn 2013-11-28 07:01:48 EST
Backport proposed internally as:

  https://code.engineering.redhat.com/gerrit/16461
Comment 10 Nir Magnezi 2013-12-16 05:21:01 EST
Verified NVR: python-django-horizon-2013.2-8.el6ost.noarch

Repeated 'Steps to Reproduce' in comment #0
launched 4 instance, 2 small and 2 medium.

Result:
it took a couple of minutes to update, but all instances types were listed in the dropdown list.
Comment 12 errata-xmlrpc 2013-12-19 19:37:42 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1859.html

Note You need to log in before you can comment on or make changes to this bug.