Bug 1033051 - drools-spring-legacy5 references kie-api instead of legacy drools 5 api
drools-spring-legacy5 references kie-api instead of legacy drools 5 api
Status: CLOSED CURRENTRELEASE
Product: JBoss BRMS Platform 6
Classification: JBoss
Component: BRE (Show other bugs)
6.0.0
Unspecified Unspecified
high Severity high
: ER6
: 6.0.0
Assigned To: Mario Fusco
Marek Winkler
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-21 08:26 EST by Marek Winkler
Modified: 2014-08-06 16:18 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:18:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marek Winkler 2013-11-21 08:26:59 EST
Description of problem:

Class drools-spring-legacy5/src/main/java/org/drools/container/spring/beans/persistence/DroolsSpringJpaManager.java references org.kie.api.runtime.Environment, but it should reference org.drools.runtime.Environment.

Similar problem is in drools-spring-legacy5/org/drools/container/spring/beans/KnowledgeBaseBeanFactory.java: org.kie.api.runtime.rule.AccumulateFunction is used instead of org.drools.runtime.rule.AccumulateFunction.

Other classes could be affected as well.

Setting the priority to high because this bug breaks backward compatibility.

Version-Release number of selected component (if applicable):

Drools 6.0.0-SNAPSHOT
BRMS 6.0.0 ER4
Comment 1 Mario Fusco 2013-11-25 10:40:17 EST
Fixed Environment compatibility with https://github.com/droolsjbpm/drools/commit/0138c4e29 and https://github.com/droolsjbpm/droolsjbpm-integration/commit/a2e83cf78

I don't think it is possible to achieve the same with the AccumulateFunction.
Comment 2 Marek Winkler 2014-01-10 06:42:00 EST
Verified the Environment fix on BRMS 6.0.0 ER7.

I will investigate the AccumulateFunction further and file another bug, if needed.

Note You need to log in before you can comment on or make changes to this bug.