Bug 1033062 - License of spacewalk-branding needs to be changed
License of spacewalk-branding needs to be changed
Status: CLOSED CURRENTRELEASE
Product: Spacewalk
Classification: Community
Component: Release (Show other bugs)
2.1
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Clifford Perry
Red Hat Satellite QA List
: Reopened
Depends On:
Blocks: space21
  Show dependency treegraph
 
Reported: 2013-11-21 08:51 EST by Johannes Renner
Modified: 2014-03-04 08:08 EST (History)
2 users (show)

See Also:
Fixed In Version: spacewalk-branding-2.1.20-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-04 08:07:05 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Johannes Renner 2013-11-21 08:51:34 EST
Description of problem:

The license of the spacewalk-branding package needs to be changed since from now on the following css frameworks, fonts and icons will be included with the package:

- Twitter Bootstrap (Apache-2.0)
- Font Awesome (MIT and OFL-1.1)
- Roboto Font (Apache-2.0)

Given our own GPL-2.0 sources we would probably end up with an aggregate:

"Apache-2.0 and GPL-2.0 and MIT and OFL-1.1"

Version-Release number of selected component (if applicable):

2.1.8

Steps to Reproduce:

Look at spacewalk-branding.spec and the contents of the package.

Actual results:

License is GPLv2.

Expected results:

License should include the licenses of included css frameworks, fonts and icons.
Comment 1 Michael Mráka 2014-01-17 05:22:30 EST
Twitter Bootstrap has been moved to separate package bootstrap-3.0.0.
Comment 2 Michael Mráka 2014-01-17 09:28:08 EST
Also Font Awesome and Roboto font has been moved to separate packages (font-awesome, roboto) so there's no more need to change license of spacewalk-branding.
Comment 3 Matej Kollar 2014-03-04 08:07:05 EST
Spacewalk 2.1 has been released.
https://fedorahosted.org/spacewalk/wiki/ReleaseNotes21
Comment 4 Matej Kollar 2014-03-04 08:08:41 EST
Spacewalk 2.1 has been released.
https://fedorahosted.org/spacewalk/wiki/ReleaseNotes21

Note You need to log in before you can comment on or make changes to this bug.