This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1033070 - owncloud synchronisation impossible
owncloud synchronisation impossible
Status: CLOSED DUPLICATE of bug 1022647
Product: Fedora
Classification: Fedora
Component: openssl (Show other bugs)
19
All Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Tomas Mraz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-21 09:02 EST by Dominique MAGNE
Modified: 2013-11-26 03:07 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-22 10:21:23 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dominique MAGNE 2013-11-21 09:02:37 EST
Description of problem:
Impossible de se connecter sur les serveurs owncloud (https://my.owndrive.com)  depuis la mise à jour du package openssl : version 1.0.1e-4 à 1.0.1e-28 et supérieur.

Version-Release number of selected component (if applicable):


How reproducible:
Mettre à jour les package openssl et openssl-lib
Essayer de synchroniser le service

downgrade openssl vers 1.0.1e-4 : synchronisation fonctionnelle


Steps to Reproduce:
1. Installer owncloud : owncloud-csync-libs-0.90.4-1 et mirall-1.4.2-3
2. Lancer le service : owncloud --logwindow
3. Impossibilité d'accéder au serveur owncloud (my.owndrive.com)

ASTUCE: test avec lynx : lynx https://my.owndrive.com/status.php

Actual results:
retrying connection without TLS, unable to make secure connection to remote host

Expected results:
{"installed":"true","version":"5.0.25","versionstring":"5.0.13","edition":""}


Additional info:
Comment 1 Gregor Tätzner 2013-11-21 14:26:42 EST
I'm not following. english please
Comment 2 Dominique MAGNE 2013-11-22 03:20:18 EST
Description of problem:
Unable to connect to the servers owncloud (https://my.owndrive.com) from the update package openssl: 1.0.1e-4 to 1.0.1e-28 and higher.

How reproducible:
Update package openssl and openssl-lib
Try to synchronize the service owncloud
==> synchronization failed : closed connection

downgrade openssl to 1.0.1e-4: 
==> functional synchronization

Steps to Reproduce:
1. Install owncloud: owncloud-csync-libs-0.90.4-1-1.4.2-3 ; mirall (deps)
2. Start the service: "owncloud --logWindow"
3. Unable to access server owncloud (my.owndrive.com)

Or TIP: test lynx : lynx https://my.owndrive.com/status.php

Actual results:
retrying connection without TLS, Unable to make secure connection to remote host

Expected results:
{"installed": "true", "version": "5.0.25", "VersionString": "5.0.13", "edition": ""}
Comment 3 Gregor Tätzner 2013-11-22 09:49:38 EST
(In reply to Dominique MAGNE from comment #2)
> Or TIP: test lynx : lynx https://my.owndrive.com/status.php
> 
> Actual results:
> retrying connection without TLS, Unable to make secure connection to remote
> host
> 
> Expected results:
> {"installed": "true", "version": "5.0.25", "VersionString": "5.0.13",
> "edition": ""}

dunno, works for me
Comment 4 Dominique MAGNE 2013-11-22 10:06:43 EST
The problem seems to exist only with server : my.owndrive.com
Comment 5 Tomas Mraz 2013-11-22 10:21:23 EST
Please update the openssl to latest update from Fedora.

*** This bug has been marked as a duplicate of bug 1022647 ***
Comment 6 Dominique MAGNE 2013-11-22 11:37:19 EST
the latest version has not corrected the problem.
Moreover, since it is the bug fix 1022647 that the problem occurred
Comment 7 Tomas Mraz 2013-11-25 02:55:42 EST
Which openssl version do you have? I am able to connect to the https://my.owndrive.com/status.php with the current openssl from updates without problems.
Comment 8 Dominique MAGNE 2013-11-26 03:07:41 EST
my version is openssl-1.0.1e-30.fc19.

Note You need to log in before you can comment on or make changes to this bug.