Bug 1033079 - rhevm-shell shows "host" as an option for the "list nics" option, which is invalid
rhevm-shell shows "host" as an option for the "list nics" option, which is in...
Status: CLOSED DUPLICATE of bug 1027281
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-cli (Show other bugs)
3.4.0
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Michael Pasternak
Elena
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-21 09:15 EST by Robert McSwain
Modified: 2014-01-12 20:46 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-21 09:27:57 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert McSwain 2013-11-21 09:15:56 EST
Description of problem:
RHEV 3.2 rhevm-shell 'list nics' tab-completion suggests there is a '--host' flag to specify the host / hypervisor, but the flag is really '--host-identifier'.

[RHEVM shell (connected)]# list nics
host      show-all  snapshot  template  vm
[RHEVM shell (connected)]# list nics --host <hostname>

unknown error: not enough arguments for format string

[RHEVM shell (connected)]# list nics --host-identifier <hostname>

id         : 2fc18254-1e74-4b2a-acc3-2cdd41ea2637
name       : p1p1
<snip>

Additionally, tab completing the "list nics host" completes to "list nics --host-identifier"

Version-Release number of selected component (if applicable):
RHEV 3.2

How reproducible:
Reliably

Steps to Reproduce:
1. Log into rhevm-shell, type "list nics" and hit tab twice. 
2. The output shows host as an option, but this should be host-identifier

Actual results:
"list nics host" returns "unknown error: not enough arguments for format string"

Expected results:
The option "hosts" is not shown in the possible options for commands. "host-identifier" should be shown instead.
Comment 1 Michael Pasternak 2013-11-21 09:27:57 EST
this is by design behaviour, in 3.4 it was changed to show X-identifier
from the beginning.
Comment 2 Robert McSwain 2013-11-21 10:14:41 EST
Michael,

I could not find an RFE bug for this, do you know if this was being tracked elsewhere?
Comment 4 Michael Pasternak 2013-11-21 11:07:24 EST
(In reply to Robert McSwain from comment #2)
> Michael,
> 
> I could not find an RFE bug for this, do you know if this was being tracked
> elsewhere?

it was fixed in context of Bug 1027281.
Comment 6 Michael Pasternak 2013-11-21 11:14:26 EST
(In reply to Michael Pasternak from comment #4)
> (In reply to Robert McSwain from comment #2)
> > Michael,
> > 
> > I could not find an RFE bug for this, do you know if this was being tracked
> > elsewhere?
> 
> it was fixed in context of Bug 1027281.

forgot to mention, #1027281 is target to 3.3, so you'll get this change for free,
and can validate (requested change) against this bug,

hope it helps.

*** This bug has been marked as a duplicate of bug 1027281 ***

Note You need to log in before you can comment on or make changes to this bug.