Bug 103308 - uninitialized sigset_t used in tst-cancel4.c
uninitialized sigset_t used in tst-cancel4.c
Status: CLOSED RAWHIDE
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: glibc (Show other bugs)
3.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-28 14:53 EDT by John Reiser
Modified: 2007-11-30 17:06 EST (History)
0 users

See Also:
Fixed In Version: 2.3.2-79
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-08 04:10:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description John Reiser 2003-08-28 14:53:09 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0) Gecko/20020529

Description of problem:
nptl/tst-cancel4.c forgot "sigemptyset(&mask);" after declaration and before
calling sigaddset(&mask, SIGUSR1);  Because of this, the value after sigaddset()
is undefined, which makes the test results invalid.


Version-Release number of selected component (if applicable):
glibc-2.3.2-70

How reproducible:
Always

Steps to Reproduce:
1.Inspect nptl/tst-cancel4.c for calls to sigaddset immediately after
declaration of the sigset_t.
2.
3.
    

Actual Results:  Lines 779, 822, 866 contain calls to sigaddset immediately
after declaration, without any call to sigemptyset.

Expected Results:  No such calls.

Additional info:
Comment 1 Jakub Jelinek 2003-08-29 13:22:23 EDT
Fix committed to CVS.
Comment 2 Jakub Jelinek 2003-09-08 04:10:49 EDT
And should be in glibc-2.3.2-79 and later as well.

Note You need to log in before you can comment on or make changes to this bug.