Bug 1033099 - This subscription management application has already been imported by another owner.
This subscription management application has already been imported by another...
Status: CLOSED DUPLICATE of bug 1100311
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
Nightly
x86_64 Linux
unspecified Severity medium (vote)
: Unspecified
: 6.0
Assigned To: Stephen Benjamin
Katello QA List
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-21 09:43 EST by ctf1800
Modified: 2014-09-18 11:37 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-07-25 06:18:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description ctf1800 2013-11-21 09:43:20 EST
Description of problem:
I imported a red-hat manifest (one server) i attached it to the server.
I then removed a organization that the above server was attached to
created a new organization and created a new key and then tried to import the manifest again
and it wont let me any why to get ride of the old subscription that is no longer present?

Version-Release number of selected component (if applicable):

System Information
Parameter 	Value
Application 	Katello
Authentication 	database
Directory 	/usr/share/katello
Environment 	production
Ruby 	1.9.3
Version 	1.4.14-1.el6
candlepin-0.8.29.3-1.el6.noarch
candlepin-cert-consumer-kickstart.corpr.jjkeller.local-1.0-1.noarch
candlepin-selinux-0.8.29.3-1.el6.noarch
candlepin-tomcat6-0.8.29.3-1.el6.noarch
createrepo-0.9.9-21.2.pulp.el6.noarch
elasticsearch-0.19.9-7.el6.noarch
katello-1.4.14-1.el6.noarch
katello-agent-1.4.5-1.el6.noarch
katello-all-1.4.14-1.el6.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-certs-tools-1.4.4-1.el6.noarch
katello-cli-1.4.7-1.el6.noarch
katello-cli-common-1.4.7-1.el6.noarch
katello-common-1.4.14-1.el6.noarch
katello-configure-1.4.9-1.el6.noarch
katello-configure-foreman-1.4.9-1.el6.noarch
katello-configure-foreman-proxy-1.4.9-1.el6.noarch
katello-foreman-all-1.4.14-1.el6.noarch
katello-glue-candlepin-1.4.14-1.el6.noarch
katello-glue-elasticsearch-1.4.14-1.el6.noarch
katello-glue-pulp-1.4.14-1.el6.noarch
katello-qpid-broker-key-pair-1.0-1.noarch
katello-qpid-client-key-pair-1.0-1.noarch
katello-repos-1.4.4-1.el6.noarch
katello-selinux-1.4.5-1.el6.noarch
m2crypto-0.21.1.pulp-8.el6.x86_64
mod_wsgi-3.4-1.pulp.el6.x86_64
pulp-katello-plugins-0.2-1.el6.noarch
pulp-nodes-common-2.3.0-0.16.alpha.el6.noarch
pulp-nodes-parent-2.3.0-0.16.alpha.el6.noarch
pulp-puppet-plugins-2.3.0-0.16.alpha.el6.noarch
pulp-rpm-handlers-2.3.0-0.16.alpha.el6.noarch
pulp-rpm-plugins-2.3.0-0.16.alpha.el6.noarch
pulp-selinux-2.3.0-0.16.alpha.el6.noarch
pulp-server-2.3.0-0.16.alpha.el6.noarch
python-isodate-0.5.0-1.pulp.el6.noarch
python-pulp-agent-lib-2.3.0-0.16.alpha.el6.noarch
python-pulp-bindings-2.3.0-0.16.alpha.el6.noarch
python-pulp-common-2.3.0-0.16.alpha.el6.noarch
python-pulp-puppet-common-2.3.0-0.16.alpha.el6.noarch
python-pulp-rpm-common-2.3.0-0.16.alpha.el6.noarch
python-qpid-0.14-11.el6_3.noarch
qpid-cpp-client-0.14-22.el6_3.x86_64
qpid-cpp-client-ssl-0.14-22.el6_3.x86_64
qpid-cpp-server-0.14-22.el6_3.x86_64
qpid-cpp-server-ssl-0.14-22.el6_3.x86_64
ruby193-rubygem-foreman-katello-engine-0.0.18-1.el6.noarch
ruby193-rubygem-katello-foreman-engine-0.0.10-1.el6.noarch
ruby193-rubygem-katello_api-0.0.3-2.el6.noarch
ruby193-rubygem-katello_api-doc-0.0.3-2.el6.noarch
ruby193-rubygem-ldap_fluff-0.2.2-2.el6.noarch
signo-katello-0.0.22-1.el6.noarch
How reproducible:


Steps to Reproduce:
1.create and org. and import the manifest
2.remove the org. 
3.create a new org and try to import the same manifest

Actual results:
This subscription management application has already been imported by another owner. 

Expected results:
import successfull

Additional info:
Comment 1 Bryan Kearney 2014-01-21 14:06:59 EST
Moving to Sat6 to be tracked there. Upstream bugs are moving to redmine.
Comment 2 RHEL Product and Program Management 2014-01-21 14:18:17 EST
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.
Comment 5 Stephen Benjamin 2014-07-25 06:18:14 EDT
This was fixed upstream as part of the org destroy work in BZ1100311.

*** This bug has been marked as a duplicate of bug 1100311 ***

Note You need to log in before you can comment on or make changes to this bug.