This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 103310 - Docs incorrectly say netprofiles can't be set at boot time
Docs incorrectly say netprofiles can't be set at boot time
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: rhl-cg (Show other bugs)
9
All Linux
medium Severity low
: ---
: ---
Assigned To: Tammy Fox
Tammy Fox
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-28 14:57 EDT by Need Real Name
Modified: 2007-04-18 12:57 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-29 17:06:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2003-08-28 14:57:57 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4; MultiZilla
v1.4.0.4A) Gecko/20030630

Description of problem:
Really a documentation issue:

http://www.redhat.com/docs/manuals/linux/RHL-9-Manual/custom-guide/s1-network-profiles.html

says that "A profile cannot be activated at boot time": it can and this proves
very useful once I realised!

grep netprofile /etc/rc.d/rc.sysinit

shows that all the hooks for passing netprofile= via grub are there as the boot
process correctly read /proc/cmdline.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Set up a new network profile
2. Pass netprofile=<new profile name> via grub.conf
3. Boot into the new profile
    

Actual Results:  It works.

Expected Results:  It should have worked. The documentation denies this.

Additional info:
Comment 1 Tammy Fox 2003-08-28 18:40:03 EDT
Thanks for the information. I'll try it out. I said that because when I asked
the developer about it, he told me that you couldn't activate them at boot time.
Comment 2 Tammy Fox 2003-08-29 17:06:57 EDT
A docs errata for this should appear in less than an hour on
http://www.redhat.com/docs/errata/RHL-9-Manual/.

Note You need to log in before you can comment on or make changes to this bug.