Bug 103312 - Parts off panel pushed off screen
Parts off panel pushed off screen
Status: CLOSED WORKSFORME
Product: Red Hat Raw Hide
Classification: Retired
Component: gnome-panel (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mark McLoughlin
: MoveUpstream, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-28 15:19 EDT by Alexander Farley
Modified: 2007-04-18 12:57 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-13 19:09:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Here is a screenshot of the problem. (126.66 KB, image/png)
2003-08-28 15:28 EDT, Alexander Farley
no flags Details
Screenshot of a Rawhide (updated) system... (139.70 KB, image/png)
2003-08-28 16:21 EDT, Michael Lee Yohe
no flags Details

  None (edit)
Description Alexander Farley 2003-08-28 15:19:41 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703

Description of problem:
A certain number of windows in the window listing area causes items on the right
hand side of the panel to be pushed off screen. Locking said items does not
prevent them from getting pushed off. When enough screens are open (grouping of
windows is not enabled) they are collapsed and enough space is given on the
screen for the items to be brought back onto the screen.

Version-Release number of selected component (if applicable):
gnome-panel-2.3.7-1

How reproducible:
Sometimes

Steps to Reproduce:
1.fill up panel with four open windows.
2.items to the right of the open windows are pushed off of the screen
3.
    

Actual Results:  Items were pushed off of the screen.

Expected Results:  Items would stay on the screen.

Additional info:
Comment 1 Alexander Farley 2003-08-28 15:28:16 EDT
Created attachment 94047 [details]
Here is a screenshot of the problem.
Comment 2 Michael Lee Yohe 2003-08-28 15:42:56 EDT
Were you running gnome-panel 2.3.6.x prior?
Comment 3 Michael Lee Yohe 2003-08-28 16:21:51 EDT
Created attachment 94050 [details]
Screenshot of a Rawhide (updated) system...

I am not seeing the behavior your describe.  As you can see in the attachment,
I have many different windows, but not panels are being pushed off to the side.
 What are all of your versions of Gnome and GTK+ 2?
Comment 4 Alexander Farley 2003-08-28 16:28:04 EDT
Yes, I was running 2.3.6x prior. I having been following rawhide since 2.0. This
is true of all of the programs/libraries. Everything I have is up to date. If
the problem does not exist on up to date installations of rawhide, then perhaps
the problem is on my end.

The problem is transient, when enough windows are opened each window is
collapsed and the full panel can be seen again.
Comment 5 Alexander Farley 2003-08-29 09:53:59 EDT
I created a new user account and I was able to replicate the behaviour. Perhaps
there is some package that is not up to date, but I really do not think so. As
an aside I have noticed that inheritance of previous versions can lead to this
type of unexpected notabug behaviour, but the new user account was created in
the up-to-date environment. 
However, this is a somewhat cosmetic bug and would not necessarily need to be
fixed. The clock next to my desk is just as good as the clock on my panel.
Comment 6 Alexander Farley 2004-01-17 02:41:29 EST
I have not seen this problem in a long time, this bug should be closed.

Note You need to log in before you can comment on or make changes to this bug.