Bug 1033153 - DestroyVDSCommand called after CancelMigrateVDSCommand failure when attempting to cancel multiple live migrations at a time
DestroyVDSCommand called after CancelMigrateVDSCommand failure when attemptin...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm (Show other bugs)
3.2.0
All Linux
urgent Severity urgent
: ---
: 3.2.5
Assigned To: Vinzenz Feenstra [evilissimo]
Pavel Novotny
virt
: ZStream
Depends On: 1023131
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-21 10:52 EST by rhev-integ
Modified: 2014-01-01 03:44 EST (History)
21 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
After attempting to cancel multiple live migrations, some virtual machines were killed. To fix this, when the migration is cancelled, libvirt raises an error to prevent the operation from proceeding, which also avoids calling the destination VDSM to create the virtual machine instance.
Story Points: ---
Clone Of: 1023131
Environment:
Last Closed: 2013-12-18 08:58:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 21445 None None None Never

  None (edit)
Comment 3 Charlie 2013-11-28 23:59:37 EST
Hi could I get a quick description of the cause and fix for this problem.

Thanks.
Comment 4 Pavel Novotny 2013-12-05 11:56:49 EST
Verified in sf22:
rhevm-3.2.5-0.48.el6ev.noarch
vdsm-4.13.0-0.10.beta1.el6ev.x86_64
libvirt-0.10.2-29.el6.1.x86_64

Verified according to original bug 1023131, comment 0:
1. Crete 5 VMs, run them all and wait until they're up.
2. Select all of them and start to migrate them.
3. Wait for webadmin portal to display the hourglass for each guest.
3. Click on Cancel Migration.

Result:
All initiated migrations are cancelled and VMs are still running on the "source" host.
Comment 7 Pavel Novotny 2013-12-09 08:40:44 EST
Re-verifying after realizing that one of my hosts was running newer VDSM from 3.3 RHEVM (vdsm-4.13.0-0.10.beta1.el6ev.x86_64) and not the 3.2.5 one.

Re-verified in sf22:
RHEVM: rhevm-3.2.5-0.48.el6ev.noarch
both hosts: vdsm-4.10.2-28.0.el6ev.x86_64, libvirt-0.10.2-29.el6.1.x86_64

Verification steps were the same as in comment 4, as well as were the results.
Comment 9 errata-xmlrpc 2013-12-18 08:58:55 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1832.html

Note You need to log in before you can comment on or make changes to this bug.