Bug 1033154 - Failed to compile the DS 389 1.3.2.3 version against Berkeley DB 4.2 version [NEEDINFO]
Failed to compile the DS 389 1.3.2.3 version against Berkeley DB 4.2 version
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: 389-ds-base (Show other bugs)
22
Unspecified Linux
unspecified Severity medium
: ---
: ---
Assigned To: Rich Megginson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-21 10:52 EST by Balaji Pachaimalai
Modified: 2016-07-15 16:37 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: The current code uses newer libdb features that are not present in older, but still supported, versions of libdb Consequence: The server fails to compile Fix: Check the version of libdb, and ignore the new code. Result: The server compiles and runs with older versions of libdb.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-15 16:37:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
nhosoi: needinfo? (balajip)


Attachments (Terms of Use)
Patch for 1.3.2 (2.71 KB, patch)
2014-02-11 12:24 EST, mreynolds
no flags Details | Diff

  None (edit)
Description Balaji Pachaimalai 2013-11-21 10:52:41 EST
Description of problem:

I downloaded 389 directory server source code 1.3.2.3 from link (http://port389.org/sources/389-ds-base-1.3.2.3.tar.bz2) and try to compile in my CentOS release 4.9 (Final) environment. I noticed below error message and  suspect with referring invalid Berkeley DB version.  I am currently using Berkeley DB version is db4-4.2.52-7.3.el4 and the link recommended the same. http://directory.fedoraproject.org/wiki/Building#Berkeley_DB

It looks DS 1.3.2 release version support bdb 4.7 and above. This should support for bdb 4.2 version as well.

[root@ ~]# rpm -qa | grep db4
db4-4.2.52-7.3.el4
db4-4.2.52-7.3.el4
[root@ ~]#
 
Error message:
In function `checkpoint_threadmain':
../ldap/servers/slapd/back-ldbm/dblayer.c:4789: error: `DB_COMPACT' undeclared (first use in this function)
../ldap/servers/slapd/back-ldbm/dblayer.c:4789: error: (Each undeclared identifier is reported only once
../ldap/servers/slapd/back-ldbm/dblayer.c:4789: error: for each function it appears in.)
../ldap/servers/slapd/back-ldbm/dblayer.c:4789: error: syntax error before "c_data"
../ldap/servers/slapd/back-ldbm/dblayer.c:4791: error: `inst_obj' undeclared (first use in this function)
../ldap/servers/slapd/back-ldbm/dblayer.c:4794: error: `inst' undeclared (first use in this function)
../ldap/servers/slapd/back-ldbm/dblayer.c:4795: error: `rc' undeclared (first use in this function)
../ldap/servers/slapd/back-ldbm/dblayer.c:4795: error: `db' undeclared (first use in this function)
../ldap/servers/slapd/back-ldbm/dblayer.c:4809: error: `c_data' undeclared (first use in this function)
../ldap/servers/slapd/back-ldbm/dblayer.c:4809: error: `DB_FREE_SPACE' undeclared (first use in this function)
../ldap/servers/slapd/back-ldbm/dblayer.c:4691: error: label `error_return' used but not defined
../ldap/servers/slapd/back-ldbm/dblayer.c: At top level:
../ldap/servers/slapd/back-ldbm/dblayer.c:4857: error: syntax error before '{' token
../ldap/servers/slapd/back-ldbm/dblayer.c:4858: error: `li' undeclared here (not in a function)
../ldap/servers/slapd/back-ldbm/dblayer.c:4858: error: initializer element is not constant
../ldap/servers/slapd/back-ldbm/dblayer.c:4858: warning: data definition has no type or storage class
../ldap/servers/slapd/back-ldbm/dblayer.c:4859: error: syntax error before ':' token
../ldap/servers/slapd/back-ldbm/dblayer.c:4861: error: syntax error before '->' token
../ldap/servers/slapd/back-ldbm/dblayer.c:4861: warning: data definition has no type or storage class



Version-Release number of selected component (if applicable):
389 directory server source code 1.3.2.3
http://port389.org/sources/389-ds-base-1.3.2.3.tar.bz2

How reproducible:
Refer the description

Steps to Reproduce:
Refer the description

Actual results:


Expected results:
This should support for bdb 4.2 version as well.

Additional info:
Comment 1 Rich Megginson 2013-12-02 11:52:35 EST
Upstream ticket:
https://fedorahosted.org/389/ticket/47615
Comment 2 mreynolds 2014-02-11 12:24:07 EST
Created attachment 861899 [details]
Patch for 1.3.2
Comment 3 mreynolds 2014-02-11 12:26:17 EST
I was unable to reproduce all of the errors reported, but I have fixed all the DB errors.  A new source patch has been attached.

Fixed upstream.
Comment 4 Jaroslav Reznik 2015-03-03 12:08:09 EST
This bug appears to have been reported against 'rawhide' during the Fedora 22 development cycle.
Changing version to '22'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora22
Comment 5 Noriko Hosoi 2015-04-29 15:20:57 EDT
The latest F22 build is 389-ds-base-1.3.3.10-1.fc22.

Does the problem still exist with this version?

Thanks.
Comment 6 Mike McCune 2016-03-28 19:29:09 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 7 Noriko Hosoi 2016-07-15 16:37:30 EDT
Could not reproduce the problem.

Closing the bug.

Note You need to log in before you can comment on or make changes to this bug.