Bug 1033156 - qt5-qtdeclarative ppc bootstrap build does not build on power.
qt5-qtdeclarative ppc bootstrap build does not build on power.
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: qt5-qtdeclarative (Show other bugs)
20
powerpc Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
AcceptedFreezeException
: Reopened
Depends On:
Blocks: F20FinalFreezeException F20PPCFinal
  Show dependency treegraph
 
Reported: 2013-11-21 11:00 EST by David Aquilina
Modified: 2014-06-23 20:19 EDT (History)
12 users (show)

See Also:
Fixed In Version: qt5-qtscript-5.2.0-0.5.beta1.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-04 11:52:20 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Aquilina 2013-11-21 11:00:43 EST
Description of problem:

qt5-qtdeclarative-5.2.0-0.2.alpha.fc20 (the build to bootstrap PPC) does not build: 

../3rdparty/masm/assembler/MacroAssembler.h:62:2: error: #error "The MacroAssembler is not supported on this platform."
 #error "The MacroAssembler is not supported on this platform."
  ^
In file included from compiler/qv4isel_masm.cpp:42:0:
compiler/qv4isel_masm_p.h:227:2: error: #error The JIT needs to be ported to this platform.
 #error The JIT needs to be ported to this platform.
  ^
compiler/qv4isel_masm_p.h:237:2: error: #error Stack alignment unknown for this platform.
 #error Stack alignment unknown for this platform.

Full build log is available from http://ppc.koji.fedoraproject.org/kojifiles/work/tasks/7957/1537957/build.log
Comment 1 Rex Dieter 2013-11-21 11:11:54 EST
Thanks for documenting it, I'd found this out the other day.

Looks like it is *supposed* to fall back to interpreted mode where JIT isn't supported.  That's as far as I got looking into it.
Comment 2 Kevin Kofler 2013-11-21 12:04:10 EST
Yes, and also note that the build is 5.2.0-alpha, the way the JIT options are set changed in 5.2.0-beta and 5.2.0-beta may actually work better, but we might need another round of PPC bootstrapping then (though if you have qt5-qtdoc already built, do you really still need the bootstrap options in the other packages? I thought disabling docs for bootstrapping is only needed for the stuff that qt5-qtdoc needs to build).
Comment 3 Dan Horák 2013-11-25 10:56:51 EST
I can see traces to the Mozilla JS backend in qtdeclarative and the solution in Mozilla/Xullrunner is to build with "--disable-jit" so ENABLE_JIT (and possibly others like ENABLE_YARRJIT) are not defined. If such option could be passed to the qt buildsystem, it might build.
Comment 4 Ngo Than 2013-11-25 11:07:27 EST
it's fixed in qt5-qtdeclarative-5.2.0-0.5.beta1
Comment 5 Rex Dieter 2013-11-26 09:00:14 EST
Looks like we still need some bootstrapping (ie, disabled -doc generation), on secondary archs too, re-opening. we can use this to track it
Comment 6 Fedora Update System 2013-11-26 09:01:36 EST
qt5-qtscript-5.2.0-0.5.beta1.fc20, qt5-qttools-5.2.0-0.5.beta1.fc20, qt5-qtwebkit-5.2.0-0.5.beta1.fc20, qt5-qtdeclarative-5.2.0-0.5.beta1.fc20, qt5-qtbase-5.2.0-0.7.beta1.20131108_141.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/qt5-qtscript-5.2.0-0.5.beta1.fc20,qt5-qttools-5.2.0-0.5.beta1.fc20,qt5-qtwebkit-5.2.0-0.5.beta1.fc20,qt5-qtdeclarative-5.2.0-0.5.beta1.fc20,qt5-qtbase-5.2.0-0.7.beta1.20131108_141.fc20
Comment 7 Fedora Update System 2013-11-26 12:58:49 EST
Package qt5-qtscript-5.2.0-0.5.beta1.fc20, qt5-qttools-5.2.0-0.5.beta1.fc20, qt5-qtwebkit-5.2.0-0.5.beta1.fc20, qt5-qtdeclarative-5.2.0-0.5.beta1.fc20, qt5-qtbase-5.2.0-0.7.beta1.20131108_141.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing qt5-qtscript-5.2.0-0.5.beta1.fc20 qt5-qttools-5.2.0-0.5.beta1.fc20 qt5-qtwebkit-5.2.0-0.5.beta1.fc20 qt5-qtdeclarative-5.2.0-0.5.beta1.fc20 qt5-qtbase-5.2.0-0.7.beta1.20131108_141.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-22154/qt5-qtscript-5.2.0-0.5.beta1.fc20,qt5-qttools-5.2.0-0.5.beta1.fc20,qt5-qtwebkit-5.2.0-0.5.beta1.fc20,qt5-qtdeclarative-5.2.0-0.5.beta1.fc20,qt5-qtbase-5.2.0-0.7.beta1.20131108_141.fc20
then log in and leave karma (feedback).
Comment 8 Fedora Blocker Bugs Application 2013-11-28 13:41:37 EST
Proposed as a Freeze Exception for 20-final by Fedora user sharkcz using the blocker tracking app because:

 qt5 library stack that was FTBFS on secondary arches, first there wasn't a Javascript engine in 5.1 and then qtdeclarative didn't build in pre-5.2.
Comment 9 Fedora Update System 2013-12-01 12:42:33 EST
Package qt5-qtscript-5.2.0-0.5.beta1.fc20, qt5-qttools-5.2.0-0.5.beta1.fc20, qt5-qtdeclarative-5.2.0-0.5.beta1.fc20, qt5-qtbase-5.2.0-0.7.beta1.20131108_141.fc20, qt5-qtwebkit-5.2.0-0.6.beta1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing qt5-qtscript-5.2.0-0.5.beta1.fc20 qt5-qttools-5.2.0-0.5.beta1.fc20 qt5-qtdeclarative-5.2.0-0.5.beta1.fc20 qt5-qtbase-5.2.0-0.7.beta1.20131108_141.fc20 qt5-qtwebkit-5.2.0-0.6.beta1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-22154/qt5-qtscript-5.2.0-0.5.beta1.fc20,qt5-qttools-5.2.0-0.5.beta1.fc20,qt5-qtwebkit-5.2.0-0.6.beta1.fc20,qt5-qtdeclarative-5.2.0-0.5.beta1.fc20,qt5-qtbase-5.2.0-0.7.beta1.20131108_141.fc20
then log in and leave karma (feedback).
Comment 10 Adam Williamson 2013-12-02 13:46:47 EST
Discussed at 2013-12-02 freeze exception review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2013-12-02/f20-blocker-review-%234.2013-12-02-17.02.log.txt . Accepted as a freeze exception issue as a significant bug for secondary arches whose fix is unlikely to break anything important for primary arches.
Comment 11 Fedora Update System 2013-12-04 11:52:20 EST
qt5-qtscript-5.2.0-0.5.beta1.fc20, qt5-qttools-5.2.0-0.5.beta1.fc20, qt5-qtdeclarative-5.2.0-0.5.beta1.fc20, qt5-qtbase-5.2.0-0.7.beta1.20131108_141.fc20, qt5-qtwebkit-5.2.0-0.6.beta1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.