Bug 1033162 - rg_test has exit code issues
rg_test has exit code issues
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: rgmanager (Show other bugs)
6.4
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Ryan McCabe
Cluster QE
: EasyFix
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-21 11:11 EST by Frantisek Reznicek
Modified: 2015-11-15 20:15 EST (History)
5 users (show)

See Also:
Fixed In Version: rgmanager-3.0.12.1-20.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-10-14 04:12:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Frantisek Reznicek 2013-11-21 11:11:01 EST
Description of problem:

rg_test has exit code issues.

rg_test (part of rgmanager) does not handle exit code correctly.


One example:

[root@dhcp-lab-x tmp]# rg_test test /etc/cluster/cluster.conf
Running in test mode.
I/O warning : failed to load external entity "/etc/cluster/cluster.conf"
Error parsing /etc/cluster/cluster.conf
[root@dhcp-lab-x tmp]# echo $?
0

In this particular case exit code of 0 is a defect.


Version-Release number of selected component (if applicable):
rgmanager-3.0.12.1-17.el6.x86_64


How reproducible:
100%


Steps to Reproduce:
1. rg_test test /etc/cluster/cluster.conf (when config file does not exist)
2. echo $?


Actual results:
Exit code does not reflect tool operation status.


Expected results:
Exit code should reflect tool operation status.
Comment 2 RHEL Product and Program Management 2013-11-24 12:31:30 EST
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 5 errata-xmlrpc 2014-10-14 04:12:29 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1586.html

Note You need to log in before you can comment on or make changes to this bug.