Bug 1033171 - RFE: Allow MTU to be specified
RFE: Allow MTU to be specified
Status: CLOSED DUPLICATE of bug 666556
Product: Virtualization Tools
Classification: Community
Component: libvirt (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Libvirt Maintainers
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-21 11:15 EST by David Woodhouse
Modified: 2016-04-19 16:30 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-19 16:30:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Woodhouse 2013-11-21 11:15:39 EST
I use libvirt to run a Windows virtual machine, which is unfortunately required for certain services that my company provides (and requires that I use).

I am connected to the company via a VPN, with an MTU of 1266.

There are pMTU black holes in our network, and HR are quite insistent that I am not permitted to visit the office location of those responsible, and apply percussive education until the problem is fixed.

Thus, I must work around it at my end. My options include MSS clamping on the NAT, or asking dnsmasq to advertise the smaller MTU in its DHCP responses. Both of those would need to be set up by libvirt.

If there is an existing facility in the network configuration where I can add verbatim options to the dnsmasq config such as 'dhcp-option=virbr0,26,1266', that would probably suffice...
Comment 1 Cole Robinson 2016-04-19 16:30:30 EDT
Duping to another bug which has discussions about more generalized dnsmasq option passthrough

*** This bug has been marked as a duplicate of bug 666556 ***

Note You need to log in before you can comment on or make changes to this bug.