Bug 1033207 - RFE: libguestfs inspection does not recognize Free4NAS live CD
Summary: RFE: libguestfs inspection does not recognize Free4NAS live CD
Status: CLOSED UPSTREAM
Alias: None
Product: Virtualization Tools
Classification: Community
Component: libguestfs (Show other bugs)
(Show other bugs)
Version: unspecified
Hardware: x86_64 Linux
unspecified
low
Target Milestone: ---
Assignee: Richard W.M. Jones
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-11-21 17:21 UTC by Pablo Hinojosa
Modified: 2013-12-09 16:47 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-09 16:47:06 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
outputs of 4 commands. qcow-* means * command to qcow2 installed image (43.76 KB, application/gzip)
2013-11-21 17:21 UTC, Pablo Hinojosa
no flags Details

Description Pablo Hinojosa 2013-11-21 17:21:22 UTC
Created attachment 827387 [details]
outputs of 4 commands. qcow-* means * command to qcow2 installed image

Description of problem:
NAS4Free (based on FreeBSD) is not recognized as a BSD OS. When you tried to copy with virt-copy-in a file into a qcow2 image with NAS4Free installed, the error is: 
guestfish: no operating system was found on this disk


Guestfish shell or command also does not recognize a downloaded NAS4Free iso and an installed NAS4Free qcow2 image as a FreeBSD os.


Version-Release number of selected component (if applicable):
guestfish 1.18.10


How reproducible:
always


Steps to Reproduce:
1. Download a NAS4Free iso here  http://sourceforge.net/projects/nas4free/files/latest/download?source=files
2. Run: "guestfish -vx add-ro ./NAS4Free-x64-LiveCD-9.1.0.1.847.iso : run : inspect-os"
3. 

Actual results:
the list of devices is empty

Expected results:
a list of devices 

Additional info:
I have noticed that maybe the virtio interface may cause the problem (because it is not supported by default by NAS4Free installation, so I also attach the outputs with my NAS4Free qcow2 image which can load virtio drives. 
I attach 4 files, being 2 commands with 2 different images (downloaded ISO and virtio installed NAS4Free qcow2): 
-inspector: output of virt-inspector -a image_path
-guestfish: output of  guestfish -vx add-ro image_path : run : inspect-os

Maybe related with this bug: https://bugzilla.redhat.com/show_bug.cgi?id=541618

Comment 1 Richard W.M. Jones 2013-11-22 09:03:06 UTC
As it's an ISO it's probably not related to bug 541618.
I think it's just lack of support for this image type, so
setting as an RFE.

Comment 2 Richard W.M. Jones 2013-12-09 16:47:06 UTC
I believe this should be fixed by
https://github.com/libguestfs/libguestfs/commit/7af3602f5fe63956a1a4bfa18c3ff48124d95352
in libguestfs >= 1.25.12


Note You need to log in before you can comment on or make changes to this bug.