Bugzilla will be upgraded to version 5.0 on December 2, 2018. The outage period for the upgrade will start at 0:00 UTC and have a duration of 12 hours
Bug 1033375 - Copy and Paste does not work when typing Italian in msgstr
Copy and Paste does not work when typing Italian in msgstr
Status: CLOSED CURRENTRELEASE
Product: Zanata
Classification: Retired
Component: Component-UI (Show other bugs)
3.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 3.4
Assigned To: Patrick Huang
Damian Jansen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-21 19:45 EST by Isaac Rooskov
Modified: 2015-08-06 01:55 EDT (History)
7 users (show)

See Also:
Fixed In Version: 3.2.3 (20140120-0038)
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-07-17 02:39:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
djansen: needinfo-


Attachments (Terms of Use)

  None (edit)
Description Isaac Rooskov 2013-11-21 19:45:49 EST
Description of problem:

From Francesco Valente:

Cannot copy and paste at all. When typing Italian in msgstr the
pointer goes crazy jumping from place to place making the task of
translating big entities impossible: eg.


"%s [options]\n"
"\n"
"COMMANDS:\n"
" -h, --help Show this help\n"
" --version Show version\n"
" --dump-conf Dump default configuration\n"
" --dump-modules Dump list of available modules\n"
" --dump-resample-methods Dump available resample methods\n"
" --cleanup-shm Cleanup stale shared memory "
"segments\n"
" --start Start the daemon if it is not "
"running\n"
" -k --kill Kill a running daemon\n"
" --check Check for a running daemon (only "
"returns exit code)\n"
"\n"
"OPTIONS:\n"
" --system[=BOOL] Run as system-wide instance\n"
" -D, --daemonize[=BOOL] Daemonize after startup\n"
" --fail[=BOOL] Quit when startup fails\n"
" --high-priority[=BOOL] Try to set high nice level\n"
" (only available as root, when SUID "
"or\n"
" with elevated RLIMIT_NICE)\n"
" --realtime[=BOOL] Try to enable realtime scheduling\n"
" (only available as root, when SUID "
"or\n"
" with elevated RLIMIT_RTPRIO)\n"
" --disallow-module-loading[=BOOL] Disallow module user requested "
"module\n"
" loading/unloading after startup\n"
" --disallow-exit[=BOOL] Disallow user requested exit\n"
" --exit-idle-time=SECS Terminate the daemon when idle and "
"this\n"
" time passed\n"
" --scache-idle-time=SECS Unload autoloaded samples when idle "
"and\n"
" this time passed\n"
" --log-level[=LEVEL] Increase or set verbosity level\n"
" -v Increase the verbosity level\n"
" --log-target={auto,syslog,stderr,file:PATH}\n"
" Specify the log target\n"
" --log-meta[=BOOL] Include code location in log "
"messages\n"
" --log-time[=BOOL] Include timestamps in log messages\n"
" --log-backtrace=FRAMES Include a backtrace in log messages\n"
" -p, --dl-search-path=PATH Set the search path for dynamic "
"shared\n"
" objects (plugins)\n"
" --resample-method=METHOD Use the specified resampling method\n"
" (See --dump-resample-methods for\n"
" possible values)\n"
" --use-pid-file[=BOOL] Create a PID file\n"
" --no-cpu-limit[=BOOL] Do not install CPU load limiter on\n"
" platforms that support it.\n"
" --disable-shm[=BOOL] Disable shared memory support.\n"
"\n"
"STARTUP SCRIPT:\n"
" -L, --load=\"MODULE ARGUMENTS\" Load the specified plugin module "
"with\n"
" the specified argument\n"
" -F, --file=FILENAME Run the specified script\n"
" -C Open a command line on the running "
"TTY\n"
" after startup\n"
"\n"
" -n Don't load default script file\n"


https://translate.engineering.redhat.com/webtrans/translate?project=pulseaudio&iteration=3.0&localeId=it&locale=en#view:doc;doc:pulseaudio


Version-Release number of selected component (if applicable):


How reproducible:

100%

Steps to Reproduce:
1. Go to: 
https://translate.engineering.redhat.com/webtrans/translate?project=pulseaudio&iteration=3.0&localeId=it&locale=en#view:doc;doc:pulseaudio
2. Try and copy and paste
3. Pointer goes crazy

Actual results:
Pointer goes crazy and thus copy and paste cannot be done

Expected results:
Copy and paste should work as expected, without the pointer going nuts

Additional info:
The only way to translate that big entry in
pulseaudio is to type every single word into "msgstr" taking up an
enormous amount of time.
Comment 1 Carlos Munoz 2013-11-21 20:10:28 EST
Seems to be related to that string in particular. I don't get the same problem on other (shorter) strings. The problem is not related copy-paste only as clicking on a word and typing something will make the characters appear on a completely different position of the string.

Also, as soon as I cancelled the edit, and then clicked on the string to start editing again, the problem seemed to go away and I was able to copy and paste with no issues.
Comment 2 Patrick Huang 2013-11-25 18:36:34 EST
For the time being, please switch to plain text editor (in editor options panel on the right hand side, uncheck 'use syntax highlighting editor' option. Then you should be able to do copy paste and cursor will act normal. 
I will investigate it but seems related to the syntax highlighting editor we are using.
Comment 3 Patrick Huang 2013-11-25 22:01:22 EST
chrome doesn't have the problem. Only firefox.
Comment 4 Patrick Huang 2013-11-25 22:13:24 EST
raised a bug in codemirror:
https://github.com/marijnh/CodeMirror/issues/1999
Comment 5 Patrick Huang 2014-03-04 19:31:28 EST
This should've been fixed in bug 968619. 
pull request:
https://github.com/zanata/zanata-server/pull/358
Comment 6 Damian Jansen 2014-03-05 00:43:40 EST
Ctrl-C -> Ctrl-V seems to work as expected.
In Firefox the right click menu seems to have retired from active duty.
Comment 7 Francesco Valente 2014-03-06 00:17:19 EST
Ok, that is very strange because if I try to copy and paste using my mouse, it doesn't work. It works only if I deselect the Use syntax highlighting Editor option in the Editor options panel of Zanata.

Francesco
Comment 8 Patrick Huang 2014-03-06 00:29:04 EST
(In reply to Francesco Valente from comment #7)
> Ok, that is very strange because if I try to copy and paste using my mouse,
> it doesn't work. It works only if I deselect the Use syntax highlighting
> Editor option in the Editor options panel of Zanata.
> 
> Francesco

Do you mean copy & paste option not present in right click or middle click paste? This is known as firefox restriction(bug has been raised). If ctrl-c and ctrl-v works then this bug is consider fixed. This bug is mainly to do with the cursor pointer going nuts.
Comment 9 Sean Flanigan 2014-03-20 01:53:08 EDT
Damian, the Fixed in Version seems to be older than the pull request.  Why is that?

Note You need to log in before you can comment on or make changes to this bug.