Bug 103357 - SSL errors with the latest up2date package over a rh9 box
SSL errors with the latest up2date package over a rh9 box
Status: CLOSED DUPLICATE of bug 103336
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
9
All Linux
medium Severity high
: ---
: ---
Assigned To: Adrian Likins
Fanny Augustin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-29 05:56 EDT by Need Real Name
Modified: 2007-04-18 12:57 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:58:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2003-08-29 05:56:54 EDT
Description of problem:

# up2date -l
There was an SSL error: [('SSL routines', 'SSL3_GET_SERVER_CERTIFICATE',
'certificate verify failed')]
A common cause of this error is the system time being incorrect. Verify that the
time on this system is correct.

The system time and date is correct since I use rdate from crontab.


Version-Release number of selected component (if applicable):
up2date-3.1.23.1-5


How reproducible:
Always.
It appears suddenly, the up2date service was running without problems last days.


Steps to Reproduce:
1. up2date -l or anything option
2.
3.
    
Actual results:
Can use redhat network service at all.


Expected results:
List the new packages and update them, of course.


Additional info:
I tried to use stunnel as I read in other bugs reports at bugzilla, but I couldn't:

# /usr/sbin/stunnel -r xmlrpc.rhn.redhat.com:443 -cf -v 2 -A
/usr/share/rhn/RHNS-CA-CERT
2003.08.29 11:48:20 LOG3[18651:1076046944]: -r: No such file or directory (2)

It's strange, isn't it?
Comment 1 Need Real Name 2003-08-29 06:00:06 EDT
Sorry, I wrote...

Actual results:
Can use redhat network service at all.

instead of...

Actual results:
Can't use redhat network service at all.

I research into bugzilla and I am can confirm there is no time or date problems:
# date
vie ago 29 11:58:48 CEST 2003

neither dns problems:
# host xmlrpc.rhn.redhat.com
xmlrpc.rhn.redhat.com has address 66.187.232.101
Comment 2 Bill Nottingham 2003-08-29 08:53:47 EDT

*** This bug has been marked as a duplicate of 103336 ***
Comment 3 Red Hat Bugzilla 2006-02-21 13:58:20 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.