Bug 103379 - rpm hangs upon using
Summary: rpm hangs upon using
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
(Show other bugs)
Version: 9
Hardware: i686 Linux
high
high
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-08-29 15:09 UTC by Jack Malmostoso
Modified: 2005-10-31 22:00 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-01 16:37:59 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jack Malmostoso 2003-08-29 15:09:38 UTC
Description of problem:
When using ANY operation involving the rpm command (rpm, or apt-get), rpm hangs 
giving this output:

rpmdb:unable to join environment
error:db4 error(11) from dbenv->open:resource temporarily unavailable (11)
error:cannot open Packages database in /var/lib/rpm

This happens when 4/5 rpm commands are issued.
Upon reboot rpm works, but breaks after a few usages: I tried to download all of 
the 4.2-1 packages at rpm.org and I could install them after rebooting. Then I 
tried rpm -qa to see if anything changed, but it hanged.
I rebooted another time and it worked for three rpm -qa | grep <name>, then 
stopped.

Version-Release number of selected component (if applicable):
rpm 4.2-1

How reproducible:
always

Steps to Reproduce:
1.use the rpm command a few times (few lower than 10)
2.rpm hangs
3.
    
Actual results:


Expected results:


Additional info:

Comment 1 Jeff Johnson 2003-09-01 14:48:13 UTC
Try
    rm -f /var/lib/rpm/__db*
Does that fix?

Comment 2 Jack Malmostoso 2003-09-01 15:40:47 UTC
I have tried it (i read the page on rpm.org) and this far everything looks good, 
but I must say I didn't make an intensive use of RPM.
But I'm optimistic :-)
Thank you for now!


Note You need to log in before you can comment on or make changes to this bug.