Bug 1033870 - F21-RC5 x68_64: wine conflicts with wine-wow-1.7.30-1.fc21.i686 when using kickstart option --multilib
Summary: F21-RC5 x68_64: wine conflicts with wine-wow-1.7.30-1.fc21.i686 when using ki...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: wine
Version: 21
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Andreas Bierfert
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-11-23 22:04 UTC by Edgar Hoch
Modified: 2015-02-06 04:04 UTC (History)
8 users (show)

Fixed In Version: wine-1.7.35-1.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-06 03:59:47 UTC
Type: Bug


Attachments (Terms of Use)
Package section of my kickstart file used for test installation (5.48 KB, text/plain)
2013-11-23 22:04 UTC, Edgar Hoch
no flags Details
File packaging.log of F20 TC3 test installation containing the error message (927.08 KB, text/plain)
2013-12-02 20:03 UTC, Edgar Hoch
no flags Details

Description Edgar Hoch 2013-11-23 22:04:54 UTC
Created attachment 828159 [details]
Package section of my kickstart file used for test installation

Description of problem:
I have tried to install Fedora 20 TC2 with kickstart using my usual configuration from Fedora 19 (I have adapted the paths, etc., of course).

The installation stops with the message:

wine conflicts with wine-wow-1.7.5-1.fc20.i686

I do not explicit require the packages wine or wine-wow. It seams that wine is required by kde-workspace-libs and that wine requires wine-wow.


Version-Release number of selected component (if applicable):
Fedora 20 TC2 x86_64 iso image
Kickstart file with package list as in the attachment

How reproducible:
Always.

Steps to Reproduce:
1. Create a kickstart file using the package list as in the attachment.
2. Use Fedora 20 TC2 x86_64 iso image as installation source.
3. Start kickstart installation (e.g. using pxe).

Actual results:
Error message:
wine conflicts with wine-wow-1.7.5-1.fc20.i686

Expected results:
No error message, installation completes successfully.

Comment 1 Andreas Bierfert 2013-12-02 18:51:04 UTC
Actually what you are seeing is a wine(x86-64) conflicting with wine-wow(x86-32) which is correct.
Seems to me something is wrong with multilib as only wine(x86-64) or wine(x86-32) can be installed (so the x86-64 version has support for x86-32 as well).

Comment 2 Edgar Hoch 2013-12-02 20:03:35 UTC
Created attachment 831765 [details]
File packaging.log of F20 TC3 test installation containing the error message

Thanks for the responce.

I tried to install F20 TC3. I get the same result (same error message).

I attached the packaging.log file of this installation (until it stops displaying the error message).

I found these two lines:

19:29:40,526 DEBUG yum.verbose.YumBase: Quick matched kde-workspace-libs-4.11.3-1.fc20.x86_64 to require for libkwineffects.so.1()(64bit)
19:29:45,072 DEBUG yum.verbose.YumBase: TSINFO: Marking wine-wow-1.7.5-1.fc20.i686 as install for wine-1.7.5-1.fc20.i686

But I do not found any requirements for wine i686.

I don't know how the kickstart package option "--multilib" works.
Is it the case that the requirement of "libkwineffects.so.1()(64bit)" requires the same lib in 32bit too?

If wine 64bit provides 32bit too, why does 32bit packages still exists in 64bit repo? Or: Why cannot co-exist 64bit and 32bit packages, each provides binaries only for there architecture?

I have looked at the wine spec file but I don't understand why the files in wine-wow are not integrated in wine-core - the specification already contains many if conditions...

Comment 3 Andreas Bierfert 2013-12-04 17:45:49 UTC
I am not a kickstart expert but my first guess was that it has something to do with the multilib option.

libKWINeffects has actually nothing to to with wine (and is certainly not the trigger here).

The wine dependencies on x86-64 are a bit more complicated. wine needs most of the x86-32 bit stuff to be able to run 32bit windows applications on 64bit, just not what is included in wine-wow(x86-32).

Comment 4 Edgar Hoch 2014-12-04 17:31:29 UTC
The problem still exists with Fedora 21 RC5 with wine-wow-1.7.30-1.fc21.i686 when using the kickstart package option "--multilib".

Comment 5 Michael Cronenworth 2014-12-04 17:45:46 UTC
I'd be inclined so say this is an ananconda bug since "yum install wine" works just fine and there is no indication in your log file as to what is pulling in wine.

Comment 6 David Shea 2014-12-04 18:00:31 UTC
The kickstart is using %packages --multilib

> I'd be inclined so say this is an ananconda bug since "yum install wine"
> works just fine

No it doesn't.

# echo -e  '[main]\nmultilib_policy = all' > multilib.conf
# yum --config multilib.conf install wine
...
--> Processing Conflict: wine-1.7.30-1.fc20.x86_64 conflicts wine-wow(x86-32) = 1.7.30-1.fc20
--> Finished Dependency Resolution
Error: wine conflicts with wine-wow-1.7.30-1.fc20.i686
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Comment 7 Michael Cronenworth 2014-12-04 19:15:17 UTC
Well, David, yes, that won't work, but wine dependencies are a bit complicated.

1) So I looked at comps. Wine is part of "system-tools", so there's the source of where wine is being pulled in. This is why I initially reassigned the bug, but there is no issue here.

2) The wine-wow package for both arches can't be installed at the same time. They contain the arch-specific /bin binary to run wine in the appropriate arch mode. Wine is a unique package in this way. We can't rename the binary file either without source changes.

Andreas, one way around having wine-wow conflict would be to use alternatives. Would you be against that?

Comment 8 Fedora Update System 2015-01-26 04:16:39 UTC
wine-1.7.35-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/wine-1.7.35-1.fc21

Comment 9 Fedora Update System 2015-01-26 04:21:17 UTC
wine-1.7.35-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/wine-1.7.35-1.fc20

Comment 10 Fedora Update System 2015-01-27 02:55:33 UTC
Package wine-1.7.35-1.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing wine-1.7.35-1.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-1171/wine-1.7.35-1.fc21
then log in and leave karma (feedback).

Comment 11 Fedora Update System 2015-02-06 03:59:47 UTC
wine-1.7.35-2.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2015-02-06 04:04:29 UTC
wine-1.7.35-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.