This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 103388 - PHP 4.3.2 Src RPM missing dependencies
PHP 4.3.2 Src RPM missing dependencies
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: php (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-29 13:14 EDT by Steve Grubb
Modified: 2007-04-18 12:57 EDT (History)
0 users

See Also:
Fixed In Version: 4.3.3-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-07 18:28:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Steve Grubb 2003-08-29 13:14:05 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.0.2) Gecko/20030716

Description of problem:
The src rpm for 4.3.2-7 is missing some dependencies for a successful build.

1) libtool >= 1.4.3

2) libelf-devel

Version-Release number of selected component (if applicable):
php-4.3.2-7

How reproducible:
Always

Steps to Reproduce:
1. rpm -ivh php-4.3.2-7.src.rpm
2. rpmbuild -bb /usr/src/redhat/SPEC/php.spec
    

Actual Results:  It builds for a while and then stops saying that libtool must
be >= 1.4.3.

After upgrading libtool and re-running step 2, it compiles for a long time and
then stops with a linking error in snmp.la under the build-cgi script.

Expected Results:  RPM successfully written to /usr/src/redhat/RPMS/i386

Additional info:

Here's the fix, add the following at line 57 of php.spec:

BuildRequires: libtool >= 1.4.3, libelf-devel

rpmbuild should report this prior to [erforming a build. It much less
frustrating when you know what has to be installed before building. It should
also be noted that the static libelf library is kept in the libelf-devel
package, rather than the plain libelf package.
Comment 1 Joe Orton 2003-09-01 09:08:10 EDT
Thanks for the report, I'll add the libtool buildprereq.  Can you post the error
which from when libelf-devel is missing?  It might be that net-snmp-devel should
require: libelf-devel rather than adding that to php.
Comment 2 Steve Grubb 2003-09-01 10:21:36 EDT
As requested, here's the output when libelf-devel was removed:

checking for SNMP support... yes, shared
checking for net-snmp-config... /usr/bin/net-snmp-config
checking for snmp_parse_oid... no
checking for init_snmp in -lnetsnmp... no
configure: error: SNMP sanity check failed. Please check config.log for more
information.
error: Bad exit status from /var/tmp/rpm-tmp.32233 (%build)

As you can see, it dies in configure.

# nm /usr/lib/libnetsnmp.a | grep init_snmp
000003b0 t _init_snmp
00000aa0 T init_snmp

So, the failure in configure must be due to something else. It was traced to
libelf not having libelf.a in it. This is on a RedHat 8.0 machine, but I think 9
is the same way.
Comment 3 Joe Orton 2003-09-07 18:28:06 EDT
libtool build prereq added in 4.3.3-1; if you like, please file the net-snmp bug
separately against net-snmp.

Note You need to log in before you can comment on or make changes to this bug.