This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 1033924 - Update packages to SFML-2.1
Update packages to SFML-2.1
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: SFML (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Julian Sikorski
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-24 06:05 EST by Hans de Goede
Modified: 2014-03-01 22:42 EST (History)
5 users (show)

See Also:
Fixed In Version: SFML-2.1-1.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-01 22:42:54 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Hans de Goede 2013-11-24 06:05:30 EST
Hi All,

Robert Arkiletian has contacted me to update SFML to version 2.1, as I'm the last person to make changes to SFML. But I'm not the maintainer, and even if I was the maintainer this would require some coordination. So I thought it would be best to file a bug to coordinate and track this.

I've checked the 2.1 release's public headers against 2.0, and although there are no API changes there are silent ABI changes! To be precise the sf::Window class has gotten a new m_size data member, growing the object size, and the sf::Shader class has gotten a new m_params data member,
also growing the object size. But the soname has not changed!

This is bad, can someone (Jonathan?) please contact upstream about this and explain to them that adding new data members (or virtual function members) breaks ABI, and that if they do that they should change the soname of the libs ?

Currently the only package depending on SFML is derelict. so I suggest that we:
1) Update SFML to 2.1 (don't forget to strip the non free fonts again)
2) Add to buildroot
3) rebuild derelict against new SFML
4) Push both in a single update

I've already more or less prepared step 1. So if everyone agrees I can do the above for f20+
Comment 1 Julian Sikorski 2013-11-24 06:13:23 EST
I agree, please feel free to go ahead.
Comment 2 Hans de Goede 2014-02-10 18:26:53 EST
Sorry it took so long, but I've finally build SFML-2.1 for F-20+.

Jullian, can you please rebuild derelict in both rawhide and F20 ? I've already created a buildroot override for F-20: https://admin.fedoraproject.org/updates/override/edit?build=SFML-2.1-1.fc20

And once derelict is build for F-20, can you please create an update in bodhi containing both the SFML-2.1 as well as the new derelict build, and make it close this bug when it goes stable?

Note I've decided to leave F-19 as is, let me know if you prefer to update F-19 too, then I'll fire of a build for F-19 too.
Comment 3 Julian Sikorski 2014-02-11 12:15:49 EST
I don't have commit access to derelict. Jonathan?
Comment 4 Hans de Goede 2014-02-11 14:32:52 EST
I have proven packager rights, so if Jonathan does not get around to this, I can do it. Can you please ping me if Jonathan has not responded before the weekend ?
Comment 5 Michael Schwendt 2014-02-11 15:42:18 EST
Jonathan has not responded since November, and he's not on the commit acl for derelict either. I've given up in bug 997679 (the rename request for sfml).
Comment 6 Hans de Goede 2014-02-11 17:24:04 EST
Hi All,

Ok, so derelict is cicku's package, and cicku is on the CC of this bug. Cicku, can you rebuild derelict in F-20+ against the new SFML please? Once it is build someone needs to also create an update with both the new SFML and derelict in there. I can do that if you want me to, either way let me know how you want to handle this.

Thanks & Regards,

Hans
Comment 7 Christopher Meng 2014-02-11 18:58:38 EST
I can do this on Thursday.
Comment 8 Hans de Goede 2014-02-12 02:25:58 EST
Hi,

(In reply to Christopher Meng from comment #7)
> I can do this on Thursday.

Excellent, thanks for working on this.

Regards,

Hans
Comment 9 Fedora Update System 2014-02-17 07:43:26 EST
SFML-2.1-1.fc20,derelict-3-25.20131023git4ae13ab.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/SFML-2.1-1.fc20,derelict-3-25.20131023git4ae13ab.fc20
Comment 10 Fedora Update System 2014-02-18 08:42:46 EST
Package SFML-2.1-1.fc20, derelict-3-25.20131023git4ae13ab.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing SFML-2.1-1.fc20 derelict-3-25.20131023git4ae13ab.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-2697/SFML-2.1-1.fc20,derelict-3-25.20131023git4ae13ab.fc20
then log in and leave karma (feedback).
Comment 11 Fedora Update System 2014-03-01 22:42:54 EST
SFML-2.1-1.fc20, derelict-3-25.20131023git4ae13ab.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.