Bug 1033989 - Please build polarssl for EPEL 5
Summary: Please build polarssl for EPEL 5
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: polarssl
Version: el5
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Mads Kiilerich
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 991689
TreeView+ depends on / blocked
 
Reported: 2013-11-25 00:59 UTC by Robert Scheck
Modified: 2013-12-11 19:34 UTC (History)
2 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2013-12-11 19:34:19 UTC


Attachments (Terms of Use)
build.log with failure on Fedora EPEL 5 (436.33 KB, text/plain)
2013-11-25 01:18 UTC, Robert Scheck
no flags Details

Description Robert Scheck 2013-11-25 00:59:23 UTC
Description of problem:
I am packaging dislocker also for Fedora EPEL 5 and it depends on polarssl.
Unfortunately there is no polarssl package for Fedora EPEL 5, yet. Would it
be possible to branch polarssl also for EPEL 5 and just ship there the same
package version like in Fedora EPEL 6, please?

Version-Release number of selected component (if applicable):
polarssl-1.3.2-1.el6

Actual results:
No polarssl-1.3.2-1.el5

Expected results:
polarssl-1.3.2-1.el5 ;-)

Additional info:
Please let me know if you do not have any interest in Fedora EPEL 5, thanks.

Comment 1 Mads Kiilerich 2013-11-25 01:10:07 UTC
The package do not build on EL5. Some kind of cmake problem. I haven't tried hard enough to figure out what the problem is. If you can fix that then it shouldn't be a problem to maintain it afterwards. ;-)

Comment 2 Robert Scheck 2013-11-25 01:18:36 UTC
Created attachment 828464 [details]
build.log with failure on Fedora EPEL 5

Comment 3 Robert Scheck 2013-11-25 01:54:32 UTC
Okay, the fix is quite trivial: Even BuildRoot is not required for EL-6 and
later, it is required for EL-5 ($RPM_BUILD_ROOT is based on that). If it is
not too much hassle, it would make sense to keep this patch in master, even
it isn't required but it allows one *.spec over all branches, I guess?

--- snipp ---
diff --git a/polarssl.spec b/polarssl.spec
index 37707f3..f44a076 100644
--- a/polarssl.spec
+++ b/polarssl.spec
@@ -12,6 +12,8 @@ BuildRequires:  cmake
 BuildRequires:  doxygen
 BuildRequires:  graphviz
 
+BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+
 %description
 PolarSSL is a light-weight open source cryptographic and SSL/TLS
 library written in C. PolarSSL makes it easy for developers to include
--- snapp ---

Comment 4 Fedora Update System 2013-11-26 01:11:35 UTC
polarssl-1.3.2-1.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/polarssl-1.3.2-1.el5

Comment 5 Fedora Update System 2013-11-26 20:44:01 UTC
polarssl-1.3.2-1.el5 has been pushed to the Fedora EPEL 5 testing repository.

Comment 6 Fedora Update System 2013-12-11 19:34:19 UTC
polarssl-1.3.2-1.el5 has been pushed to the Fedora EPEL 5 stable repository.


Note You need to log in before you can comment on or make changes to this bug.