Bug 1034049 - ip -6 addrlabel return incorrect error message
Summary: ip -6 addrlabel return incorrect error message
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: iproute
Version: 6.6
Hardware: All
OS: Linux
unspecified
low
Target Milestone: rc
: ---
Assignee: Pavel Šimerda (pavlix)
QA Contact: Jaroslav Aster
URL:
Whiteboard:
Depends On:
Blocks: 1100271
TreeView+ depends on / blocked
 
Reported: 2013-11-25 07:46 UTC by Hangbin Liu
Modified: 2015-07-22 06:40 UTC (History)
3 users (show)

Fixed In Version: iproute-2.6.32-35.el6
Doc Type: Bug Fix
Doc Text:
Previously, the "ip -6 addrlabel" command returned an incorrect error message that contained "inet" instead of "inet6". To fix this bug, the error message has been changed to include "inet" for IPv4 addresses and "inet6" for IPv6 addresses.
Clone Of:
: 1100271 (view as bug list)
Environment:
Last Closed: 2015-07-22 06:40:34 UTC


Attachments (Terms of Use)
Display the correct inet/inet6 string (472 bytes, patch)
2013-11-25 08:46 UTC, Petr Šabata
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1331 normal SHIPPED_LIVE iproute bug fix and enhancement update 2015-07-20 17:53:02 UTC

Description Hangbin Liu 2013-11-25 07:46:44 UTC
Description of problem:
ip -6 addrlabel return incorrect error message

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. ip -6  addrlabel add prefix 1.1.1.1/24 label 123
2.
3.

Actual results:
Error: an inet prefix is expected rather than "1.1.1.1/24".


Expected results:
Error: an inet6 prefix is expected rather than "1.1.1.1/24".

Additional info:

Comment 2 Petr Šabata 2013-11-25 08:46:58 UTC
Created attachment 828568 [details]
Display the correct inet/inet6 string

Comment 3 Hangbin Liu 2013-11-26 01:34:03 UTC
How about correct the address message at the same time

diff --git a/lib/utils.c b/lib/utils.c
index 4e9c719..eb92414 100644
--- a/lib/utils.c
+++ b/lib/utils.c
@@ -487,7 +487,7 @@ int get_addr(inet_prefix *dst, const char *arg, int family)
                exit(1);
        }
        if (get_addr_1(dst, arg, family)) {
-               fprintf(stderr, "Error: an inet address is expected rather than \"%s\".\n", arg);
+               fprintf(stderr, "Error: an %s address is expected rather than \"%s\".\n", (family == AF_INET6 ? "inet6" : "inet") ,arg);
                exit(1);
        }
        return 0;
@@ -500,7 +500,7 @@ int get_prefix(inet_prefix *dst, char *arg, int family)
                exit(1);
        }
        if (get_prefix_1(dst, arg, family)) {
-               fprintf(stderr, "Error: an inet prefix is expected rather than \"%s\".\n", arg);
+               fprintf(stderr, "Error: an %s prefix is expected rather than \"%s\".\n", (family == AF_INET6 ? "inet6" : "inet") ,arg);
                exit(1);
        }
        return 0;

Comment 10 errata-xmlrpc 2015-07-22 06:40:34 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1331.html


Note You need to log in before you can comment on or make changes to this bug.