Bug 103419 - RFE: add netplug or ifplugd deamons for network cable controlled network activation
RFE: add netplug or ifplugd deamons for network cable controlled network acti...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: net-tools (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Radek Vokal
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-29 18:21 EDT by Jef Spaleta
Modified: 2007-04-18 12:57 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-28 21:42:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jef Spaleta 2003-08-29 18:21:23 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.7 (X11; Linux i686; U;) Gecko/20030131

Description of problem:
Good Morning!

Being the freshmeat troll that i am. I noticed the new announcement
for netplug:
http://www.red-bean.com/~bos/

and then i was told about ifplugd:
http://www.stud.uni-hamburg.de/users/lennart/projects/ifplugd/

There maybe other project out there that try to provide the same
functionality...but these little proggies act as daemons which will
automatically configure your ethernet device when a cable is plugged in and then
unconfigure it when the cable is pulled out.

Seems really useful for lappies with wire-full networkcards. But I'd imagine its
also useful for dhcp enabled desktops as well. 

I was going to play with netplug and ifplugd on the dhcp desktop i have access
to...but i dont have a lappy which seems the most natural fit for this sort of
thing.

Anyways, please consider including one of the projects that provide this cable
sensing functionality.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
N/A
    

Actual Results:  N/A

Expected Results:  n/A

Additional info:
Comment 1 Jaap Haitsma 2003-12-14 08:22:49 EST
Installed it and it works find with Fedora Core 1. For more info see
also this post to the fedora-devel-list
http://www.redhat.com/archives/fedora-devel-list/2003-December/msg00967.html
Comment 2 Jaap Haitsma 2003-12-14 08:24:22 EST
Sorry small typo in previous comment I wanted to say it works fine
Comment 3 Bryan O'Sullivan 2003-12-15 12:04:09 EST
I'm the netplug developer, and I'll be happy to help with integrating
this into FC2, along with providing support in case of problems.
Comment 4 Phil Knirsch 2003-12-16 06:04:20 EST
Hi folks.

As the discussion on fdl seems to really point out a great interrest
in that feature i'll be looking into it over the next couple of days.
I'll review ifplugd, netplug and whatever i stumble across and let you
know here what i'd like to do in FC2.

Thanks,

Read ya, Phil
Comment 5 Bryan O'Sullivan 2003-12-16 12:29:57 EST
Sounds good.  I'll be working with David Zeuthen to adapt netplug into
the GNOME HAL, but I wouldn't hold my breath for that becoming
complete enough to use in time for FC2.  I think netplug on its own is
a decent intermediate step.
Comment 6 Jef Spaleta 2004-02-13 08:56:24 EST
Re: comment #4
so its been a couple of days
Phil, are you ready to tell us what yer looking to do for FC2?
or do i get to be surprised by running the test release?

Comment 7 Phil Knirsch 2004-02-13 09:02:56 EST
Sorry folks, i got pushed down on my priority list week after week.

I'll see if i can squeeze it in sometime next week.

Read ya, Phil
Comment 8 Forrest 2004-02-17 16:37:10 EST
I'd like this functionality as well.  I've been using ifplugd for a
while in a large corporate environment, and it is invaluable with my
laptop.

Since Bryan offered to help integrate netplug into FC2, I'd be willing
to test it.
Comment 9 Forrest 2004-02-17 17:59:10 EST
One thing that I don't like about netplug is that it replaces the
ifcfg-eth* scripts.  What happens when you add/remove a network card?
 It looks like you have to manually create/remove the
ifcfg-eth?.pre-netplug scripts or reinstall netplug.  Bryan, any ideas?

With ifplugd, I could add/remove cards without a problem.
Comment 10 Bryan O'Sullivan 2004-02-17 18:23:06 EST
That can definitely be changed.  The reason that it replaces those
config files right now is to ensure that interfaces get turned from
ONBOOT=yes to ONBOOT=no.  That's the only real difference.  If your
interfaces are already set to ONBOOT=no, it won't do anything.
Comment 11 Bryan O'Sullivan 2004-02-17 18:24:22 EST
By the way, I think the "right" thing to do would be to teach
redhat-config-network about netplug, and allow you to select a policy
for pluggable interfaces such that netplug managed them in general.
Comment 12 Forrest 2004-02-17 19:25:42 EST
Why exactly do you change the config from ONBOOT=yes to no?  Is it so
that you can only start them if they are connected?  Would netplug
still work if all cards were ONBOOT=yes, or does it actually read the
ifcfg-eth?.pre-netplug script?
Comment 13 Bryan O'Sullivan 2004-02-17 19:39:37 EST
I don't recall, to be honest.  I think netplugd was getting confused
by interfaces that were already up at start time.  I'll have to take a
look and see.
Comment 14 Forrest 2004-02-17 19:50:18 EST
Yeah, see what you can find, and let me know.  It's not a bad feature
if the network cable is not plugged in at boot.  I know I've waited
for many minutes while the network scripts timed out on a network card
that couldn't get an IP address.
Comment 15 Forrest 2004-02-18 16:03:08 EST
You may want to change the start order to something later.  netplug
starts righ after network, and before PCMCIA.  You should be able to
make it start right before boot.
Comment 16 Forrest 2004-02-18 16:51:58 EST
The problem may be that netplug starts the network even when it is
already up.  When I installed netplug and started it I got:

 netplugd: netplugd startup succeeded
 dhclient: DHCPREQUEST on eth0 to 255.255.255.255 port 67
 dhclient: DHCPACK from 1.2.3.1
 dhclient: bound to 1.2.3.4 -- renewal in 263417 seconds.
 netplugd[6257]: eth0: state INNING pid 6258 exited status 0

If the link is already up when it starts, shouldn't it just listen?
Comment 17 Bryan O'Sullivan 2004-02-18 17:17:53 EST
In principle, netplug shouldn't do anything if an interface is already
up.  In practice, it was simpler at the time to just get it to own and
manage all interfaces.  I don't think it makes much sense to have both
the regular init script and netplug try to own an interface.
Comment 18 Phil Knirsch 2004-02-19 10:55:45 EST
OK, i've looked at ifplugd and netplug and it i'll be including
netplug for several reasons:

 - It's very small (so bugs can be found and fixed quickly and easily)
 - The author has a real interest in putting it in RH  :-)
 - Code looks good and everything is already prepared for RH inclusion.

The question now remains if it should be put into net-tools or
iputils, but i think net-tools is really the right place for it.

I hope to get a new net-tools package out either tonight or tomorrow
and it should hit the development tree in the next few days then.

Read ya, Phil
Comment 19 Bryan O'Sullivan 2004-02-19 13:23:20 EST
Thanks, Phil.  I look forward to helping out :-)

Please make sure you use v1.2.1 when you're including it.  v1.2
doesn't work with ndiswrapper, which seems to be more of an
ndiswrapper bug than anything in netplug, but still...
Comment 20 Bryan O'Sullivan 2004-02-22 15:58:00 EST
netplug 1.2.2 is out, same bat time, same bat channel.
Comment 21 Bryan O'Sullivan 2004-07-28 12:19:16 EDT
netplug 1.2.7 is already in FC2.  This bug should be closed.
Comment 22 Jef Spaleta 2004-07-28 21:42:21 EDT
okay im a gonna close the bug as resolved current release since
netplug is in net-tools package as stated in the previous comment.



Note You need to log in before you can comment on or make changes to this bug.