Bug 1034218 - EAR subdeployments are not discovered for DomainDeployment
Summary: EAR subdeployments are not discovered for DomainDeployment
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Operations Network
Classification: JBoss
Component: Plugin -- JBoss EAP 6
Version: JON 3.2
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: DR01
: JON 3.3.0
Assignee: Thomas Segismont
QA Contact: Mike Foley
URL:
Whiteboard:
Keywords:
: 1091009 (view as bug list)
Depends On: 1083548
Blocks: 1119505
TreeView+ depends on / blocked
 
Reported: 2013-11-25 12:48 UTC by Libor Zoubek
Modified: 2018-12-09 17:18 UTC (History)
13 users (show)

(edit)
It was discovered that when an EAR was deployed to a managed server group, it was missing its children (subdeployments). If same EAR was deployed to a standalone server, the subdeployments were present. EAR subdeployments (and their runtime child subsystems) could not be correctly discovered. The EAP management plug-in now handles subdeployments, such as those found within an EAR, which are deployed to either standalone or managed server deployments.
Clone Of:
: 1119505 (view as bug list)
(edit)
Last Closed: 2014-12-11 14:01:32 UTC


Attachments (Terms of Use)
kitchensink-ear (99.77 KB, application/zip)
2013-11-25 12:48 UTC, Libor Zoubek
no flags Details
no-subdep (152.71 KB, image/png)
2014-02-19 14:39 UTC, Armine Hovsepyan
no flags Details
sub_dep-NA (144.86 KB, image/png)
2014-04-03 08:28 UTC, Armine Hovsepyan
no flags Details
Screenshot on inventory with master build (52.49 KB, image/png)
2014-04-03 12:59 UTC, Thomas Segismont
no flags Details
applied_operation (152.36 KB, image/png)
2014-04-03 13:13 UTC, Armine Hovsepyan
no flags Details
auto-discovery (173.59 KB, image/png)
2014-04-03 13:13 UTC, Armine Hovsepyan
no flags Details
subdeployments (206.05 KB, image/png)
2014-08-01 10:54 UTC, Armine Hovsepyan
no flags Details
subdeployments-domain (234.38 KB, image/png)
2014-08-01 11:49 UTC, Armine Hovsepyan
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 799713 None None None Never
Red Hat Bugzilla 912478 None None None Never

Internal Trackers: 912478

Description Libor Zoubek 2013-11-25 12:48:55 UTC
Created attachment 828644 [details]
kitchensink-ear

Description of problem:

JON currently cannot discover EAR subdeployments (and their runtime child subsystems)

Version-Release number of selected component (if applicable):
JON 3.2.0.ER7

How reproducible: always


Steps to Reproduce:
1. have EAP 6 in domain mode
2. deploy ear (see attachment) as domain deployment
3. assign it to all server groups
4. run discovery

Actual results:

ear is discovered on managed servers, but without any children. If you deploy the same ear to standalone server you'll see 2 subdeployments with web/ejb3/jpa runtime subsystems

Expected results: ear deployment should be discovered same way as on standalone mode


Additional info:

Comment 1 Libor Zoubek 2013-11-25 13:04:41 UTC
Setting as 3.2 blocker for further triage.

Reasons: Within JON 3.2 there has been added alot of runtime subsystems support (web,jpa,ejb (calltimes)), we do support some of them on domain mode as well (at least web subsystem - Bug 912478). We should be able to support those features regardless the way a deployment is packaged.

Comment 3 Thomas Segismont 2013-11-26 17:53:46 UTC
Fixed in master

commit d28e22f0c77f127efe6ff3f63f0f82e22c20083a
Author: Thomas Segismont <tsegismo@redhat.com>
Date:   Tue Nov 26 18:52:31 2013 +0100

Comment 8 Thomas Segismont 2014-01-10 16:11:57 UTC
Moved back to ASSIGNED as it needs to be reviewed and cherry-picked over the 3.2.x branch

Comment 9 Thomas Segismont 2014-01-16 09:27:35 UTC
Cherry-picked over bug/1034218

commit f93fa4c72831225a79788fc049d4164caa1c831a
Author: Thomas Segismont <tsegismo@redhat.com>
Date:   Tue Nov 26 18:52:31 2013 +0100

Lukas will review it

Comment 10 Lukas Krejci 2014-01-16 11:55:31 UTC
commit d7c63e2cecf690918c5f0d59de6a6e06eaf91237
Author: Thomas Segismont <tsegismo@redhat.com>
Date:   Tue Nov 26 18:52:31 2013 +0100

    Bug 1034218 - EAR subdeployments are not discovered for DomainDeployment
    (cherry picked from commit d28e22f0c77f127efe6ff3f63f0f82e22c20083a)
    
    Signed-off-by: Lukas Krejci <lkrejci@redhat.com>

Comment 11 Simeon Pinder 2014-02-18 15:08:29 UTC
Moving to ON_QA as available for testing in the following brew build:
https://brewweb.devel.redhat.com//buildinfo?buildID=336752

Note: the installed version is still JON 3.2.0.GA by design and this represents part of the payload for JON 3.2.1 also known as cumulative patch 1 for 3.2.0.GA.  How this will be delivered to customers is still being discussed.

Comment 12 Armine Hovsepyan 2014-02-19 14:37:20 UTC
still visible in DR1
screen-shot attached

Comment 13 Armine Hovsepyan 2014-02-19 14:39:12 UTC
Created attachment 865097 [details]
no-subdep

Comment 14 Thomas Segismont 2014-02-21 16:14:30 UTC
So my first commit fixed the problem of ejb, jpa ... etc runtimes not showing up on ManagedServerDeployment resources (wars in managed server). But not the problem of sub-deployments in managed server deployments...

Fixed in master

commit 88436871349b64251cc9c689a4291e6b9d9c56d6
Author: Thomas Segismont <tsegismo@redhat.com>
Date:   Fri Feb 21 16:54:28 2014 +0100

Added missing line: a Subdeployment can be a child of a ManagedServerDeployment

Comment 15 Lukas Krejci 2014-02-24 17:29:52 UTC
hmm... could not find commit 88436871349b64251cc9c689a4291e6b9d9c56d6 anywhere in the repo. have you pushed it, Thomas?

Comment 16 Thomas Segismont 2014-03-03 15:11:14 UTC
(In reply to Thomas Segismont from comment #14)
> So my first commit fixed the problem of ejb, jpa ... etc runtimes not
> showing up on ManagedServerDeployment resources (wars in managed server).
> But not the problem of sub-deployments in managed server deployments...
> 
> Fixed in master
> 
> commit 88436871349b64251cc9c689a4291e6b9d9c56d6
> Author: Thomas Segismont <tsegismo@redhat.com>
> Date:   Fri Feb 21 16:54:28 2014 +0100
> 
> Added missing line: a Subdeployment can be a child of a
> ManagedServerDeployment

Ignore Comment 14 (I forgot to push to master)

Now fixed in master

commit d327d3ffccfdde166a746f42b542150fdd70d984
Author: Thomas Segismont <tsegismo@redhat.com>
Date:   Fri Feb 21 16:54:28 2014 +0100

Added missing line: a subdeployent can be a child of a ManagedServer deployment

Comment 17 Jirka Kremser 2014-03-07 10:43:48 UTC
branch:  release/jon3.2.x
link:    https://github.com/rhq-project/rhq/commit/516a6af84
time:    2014-03-07 11:38:26 +0100
commit:  516a6af847cecd9df7f3b85d690250756e1bcd32
author:  Thomas Segismont - tsegismo@redhat.com
message: Bug 1034218 - EAR subdeployments are not discovered for DomainDeployment

    (cherry picked from commit d327d3ffccfdde166a746f42b542150fdd70d984)
    Signed-off-by: Jirka Kremser <jkremser@redhat.com>

Comment 18 Simeon Pinder 2014-04-01 20:43:56 UTC
Moving to ON_QA as available for test in newest cumulative patch build from here:
http://jon01.mw.lab.eng.bos.redhat.com:8042/dist/release/jon/3.2.1.GA/4-01-2014/
I moved the earlier build to 3-18-2014.

Comment 19 Armine Hovsepyan 2014-04-03 08:28:11 UTC
Created attachment 882144 [details]
sub_dep-NA

Comment 20 Armine Hovsepyan 2014-04-03 11:36:20 UTC
no sub-deployment resources visible - 3.2.0 with CP (#2) - screen-shot attached

Comment 21 Thomas Segismont 2014-04-03 12:59:58 UTC
Created attachment 882256 [details]
Screenshot on inventory with master build

Just tried on a recent master build and it works. How long did you wait after the "assign to server group operation" execution? It can take some time before the resource shows up.

Comment 22 Armine Hovsepyan 2014-04-03 13:13:20 UTC
Created attachment 882258 [details]
applied_operation

Comment 23 Armine Hovsepyan 2014-04-03 13:13:48 UTC
Created attachment 882259 [details]
auto-discovery

Comment 24 Armine Hovsepyan 2014-04-03 13:14:46 UTC
applied yesterday, ran auto-discovery several times, then re-ran auto-discover today, sub-resources are not yet visible. screen-shots attached

Comment 26 Thomas Segismont 2014-04-03 14:18:40 UTC
It appeared that the fix for that BZ is not included in the CP build pointed out by Comment 18

Comment 28 Larry O'Leary 2014-05-06 20:49:01 UTC
*** Bug 1091009 has been marked as a duplicate of this bug. ***

Comment 30 Simeon Pinder 2014-07-31 15:52:20 UTC
Moving to ON_QA as available to test with brew build of DR01: https://brewweb.devel.redhat.com//buildinfo?buildID=373993

Comment 32 Armine Hovsepyan 2014-08-01 10:54:40 UTC
Created attachment 923220 [details]
subdeployments

Comment 33 Armine Hovsepyan 2014-08-01 11:49:54 UTC
Created attachment 923267 [details]
subdeployments-domain

Comment 34 Armine Hovsepyan 2014-08-01 11:54:15 UTC
verified in JON 3.3 DR1  (failed for eap plugin pack #1119505)-- screen-shots attached


Note You need to log in before you can comment on or make changes to this bug.