Bug 1034248 - cgred service is missing in the latest rhel7
Summary: cgred service is missing in the latest rhel7
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libcgroup
Version: 7.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: ---
Assignee: Peter Schiffer
QA Contact: Red Hat Kernel QE team
URL:
Whiteboard:
Keywords: Regression
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-11-25 13:37 UTC by Petr Sklenar ⛄
Modified: 2014-04-28 10:34 UTC (History)
2 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2013-12-12 12:54:39 UTC


Attachments (Terms of Use)

Description Petr Sklenar ⛄ 2013-11-25 13:37:03 UTC
Description of problem:
cgred service is missing in the latest rhel7

Version-Release number of selected component (if applicable):
libcgroup-0.40-0.rc1.3.el7.x86_64
libcgroup-tools-0.40-0.rc1.3.el7.x86_64
RHEL-7.0-20131121.n.0

How reproducible:
always

Steps to Reproduce:
1. systemctl start cgred
2. yum provides */cgred
3. rpm -ql libcgroup-tools | grep cgred


Actual results:
no cgred in the rhel7

Expected results:
cgred is there

Additional info:
RHEL-7.0-20131030.1 Server x86_64:
it was there:
http://beaker-archive.app.eng.bos.redhat.com/beaker-logs/2013/11/5389/538922/1122774/17111796/TESTOUT.log

RHEL-7.0-20131121.n.0 Server x86_64
not there:
http://beaker-archive.app.eng.bos.redhat.com/beaker-logs/2013/11/5501/550126/1144434/17495278/TESTOUT.log

Comment 1 Peter Schiffer 2013-11-25 13:40:34 UTC
See bug #1016810.

Comment 4 Peter Schiffer 2013-12-12 12:54:39 UTC
Closing as this is not a bug, but a feature.

Comment 5 William Stein 2014-04-27 15:03:32 UTC
(In reply to Peter Schiffer from comment #1)
> See bug #1016810.

Even after creating an account, I get "You are not authorized to access bug #1016810."

Comment 6 Peter Schiffer 2014-04-28 10:34:17 UTC
William,

I'm sorry, I think there is some internal info in that bug. Anyway, original plan was to remove the cgred service from RHEL-7, but because of some dependencies it was returned. Now, both cgred service and systemd's Control Group Interfaces are available in RHEL-7; systemd does not mount net_prio controller so both cgroup tools should be working. But please note, that libcgroup is still deprecated in RHEL-7.

peter


Note You need to log in before you can comment on or make changes to this bug.