Bug 103431 - RFE: Add a use_static_server option macro to XFree86.spec
RFE: Add a use_static_server option macro to XFree86.spec
Status: CLOSED WONTFIX
Product: Red Hat Raw Hide
Classification: Retired
Component: XFree86 (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
: Triaged
Depends On:
Blocks: FC5Target
  Show dependency treegraph
 
Reported: 2003-08-30 02:07 EDT by Mike A. Harris
Modified: 2007-04-18 12:57 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-06 01:55:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike A. Harris 2003-08-30 02:07:04 EDT
Personal reminder tracker for RFE from John:


Date: 29 Aug 2003 14:42:27 -0400
From: John Dennis <jdennis@redhat.com>
To: Mike Harris <mharris@redhat.com>
Subject: Loadable server toggle in spec file

Hi Mike:

I often take advantage of the DebuggableBuild flag in the spec file but
since gdb doesn't work the loadable server I usually resort to disabling
the loadable server. But this requires manually editing either the spec
file of host.def to add:

#define DoLoadableServer NO

Do you think you could add a toggle to the spec file like
DebuggableBuild that would add that line to the host.def? Maybe call it
StaticServer?
Comment 5 Mike A. Harris 2005-10-06 01:55:55 EDT
Modular X.Org uses dlopen() for module loading, so can be debugged by
gdb.  Additionally, it appears to be debuginfo compatible.

The X server also can print it's own backtrace when it crashes now too.

That pretty much makes building static servers an obsolete thing in the
modular tree.

Closing bug "WONTFIX", as it doesn't make sense to do this now.

Note You need to log in before you can comment on or make changes to this bug.