Bug 1034357 - numpy missing doc module
Summary: numpy missing doc module
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: numpy
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Gwyn Ciesla
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 1032651 1051550 1051553
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-11-25 16:47 UTC by Tomas Tomecek
Modified: 2014-01-10 15:43 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of: 1032651
Environment:
Last Closed: 2014-01-10 15:43:34 UTC


Attachments (Terms of Use)
patch to build sphinx documentation (1.55 KB, patch)
2013-11-26 16:40 UTC, Tomas Tomecek
no flags Details | Diff

Description Tomas Tomecek 2013-11-25 16:47:41 UTC
Executable code from numpy.doc shouldn't be in %doc.

Also, why is sphinx documentation not being built?

+++ This bug was initially created as a clone of Bug #1032651 +++

Description of problem:
numpy missing doc module

How reproducible:
always

Steps to Reproduce:
$ python -c "import numpy.doc"

Actual results:
Traceback (most recent call last):
  File "<string>", line 1, in <module>
ImportError: No module named doc

Comment 1 Orion Poplawski 2013-11-26 03:56:05 UTC
Looks like this has been this way since at least 0.9.4.  Looks like sometime along the way, the doc/ directory became a module instead of a collection of text files.

Comment 2 Orion Poplawski 2013-11-26 05:46:35 UTC
Test out 1.8.0-3 - that should have the doc module.

As for the sphinx docs, that is failing with:

$ make html                                                                                                                                 
mkdir -p build                                                                                                                                                          
touch build/generate-stamp
mkdir -p build/html build/doctrees
LANG=C sphinx-build -b html -d build/doctrees   source build/html 
Running Sphinx v1.1.3
1.8 1.8.0
NOTE: linkcode extension not found -- no links to source generated

Looks like we are missing the sphinx.ext.linkcode module in Fedora

Comment 3 Tomas Tomecek 2013-11-26 08:20:16 UTC
You are right. But it seems that this dependency was added in numpy-1.8 because I can build documentation for 1.7 just fine:
                                             
copying static files... done
dumping search index... done
dumping object inventory... done
build succeeded, 637 warnings.
python postprocess.py html build/html/*.html

Build finished. The HTML pages are in build/html.

Although the number of warnings is quite alarming.

Comment 4 Tomas Tomecek 2013-11-26 08:48:23 UTC
After some further investigation I can see that we have sphinx-1.1 in Fedora and the extension [1] is new in version 1.2 [2] and this version of sphinx is currently in beta [3]. So I guess that when sphinx-1.2 will be released we could give it a shot and try to build & package the documentation.

[1] http://sphinx-doc.org/latest/ext/linkcode.html
[2] http://sphinx-doc.org/latest/changes.html#id8
[3] http://sphinx-doc.org/latest/changes.html

Comment 5 Tomas Tomecek 2013-11-26 16:40:17 UTC
Created attachment 829362 [details]
patch to build sphinx documentation

I've managed to build the docs today, it took some time so I'm posting patch here so anyone else wouldn't have to spent time on it.

Comment 6 Fedora Update System 2013-11-28 05:53:49 UTC
numpy-1.8.0-3.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/numpy-1.8.0-3.fc20

Comment 7 Orion Poplawski 2013-11-28 06:01:35 UTC
Thanks Tomas.  For now I've got the doc module in 1.8.0-3.fc20, and I'm building 1.7.1-7.fc19 with the doc module and the sphinx docs.  I only am shipping the html dir - not sure if the doctrees and plot_directive dirs are useful - they do not seem to referenced by anything in html anyway.

Comment 8 Tomas Tomecek 2013-11-28 10:50:42 UTC
I wasn't sure either. I think that html dir will be sufficient (apart from that, whole built documentation has 80 MB, so shipping only 40 (the html dir) will be much better).

Thanks for doing it Orion, great job!

Comment 9 Fedora Update System 2013-12-14 03:54:20 UTC
numpy-1.8.0-3.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Orion Poplawski 2014-01-10 15:43:34 UTC
Not sure why this didn't get closed.


Note You need to log in before you can comment on or make changes to this bug.