Bug 103437 - XFree86 keeps changing my symlink
XFree86 keeps changing my symlink
Status: CLOSED NOTABUG
Product: Red Hat Raw Hide
Classification: Retired
Component: XFree86 (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-30 09:54 EDT by Daniel Malmgren
Modified: 2007-04-18 12:57 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-30 10:44:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Malmgren 2003-08-30 09:54:20 EDT
I'm not quite sure if this is a bug or a feature, but it's quite annoying.

In /usr/X11R6/lib/tls/i686 there is a symlink libGL.so.1 pointing to the file
libGL.so.1.2 in the same directory. Since some programs (for example
xscreensaver) uses this link and complains about it I've tried redirecting it to
pointing at /usr/lib/tls/libGL.so.1 (which in turn points to the correct Nvidia
library) wich works out well.

My problem is that every time I restart X the symlink is restored to it's
default location. Why is this?

Version-Release number of selected component (if applicable):
4.3.0-22.1
Comment 1 Mike A. Harris 2003-08-30 10:37:18 EDT
I fail to see any bug here.  The symlink that is there is correct.  It's
not a "feature", it's just the proper way that libGL should be installed.

Jakub, do you have any comments before I close this NOTABUG?
Comment 2 Jakub Jelinek 2003-08-30 10:44:23 EDT
Yeah, that's how it should look like. If you are using NVidia's libGL, you
shouldn't have installed XFree86 libGL too earlier in the search path.
The symlink is recreated by ldconfig FYI.

Note You need to log in before you can comment on or make changes to this bug.