Bug 103454 - rpm corruption can't be cleaned up
rpm corruption can't be cleaned up
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
9
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jeff Johnson
Mike McLean
http://www.citytools.net/corrupt_rpm....
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-30 20:03 EDT by Robert S. Cauthorn
Modified: 2007-04-18 12:57 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-12-27 16:04:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert S. Cauthorn 2003-08-30 20:03:10 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.7 (X11; Linux i686; U;) Gecko/20030131

Description of problem:
Hi,

Shortly after I installed RH 9 (fresh installation) the RPM database started to
show signs of corruption. When installing rpms, some would succeed, some would
execute silently without installing anything.

When that happened, if you tried to re-install one of these "silent fail"
packages, it would fail saying the package is already installed. If you tried to
uninstall the package, it would fail saying the package *was not* installed.

Anyhow, it got gradually worse until rpm is now useless. I'd reinstall, but I've
got a *lot* of configuration and user info on the box now and it's a major hassle.

I can't do an upgrade because the upgrader seg faults when it tries to read
installed packages.

I tried using the step Jeff outlined in several usenet posts -- including using
the program he made to clean out bad headers -- but no luck.

Above you'll find a link to the tarball I created with the Packages file. HELP!!!

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. run rpm to install a package
2. rpm runs and quits without a message
3. package is not actually installed, though.
4. try to reinstall a package and it tells you the package is already installed.
5. try to uninstall the package and it says that it's not installed.
6. blech.
    

Actual Results:  nothing is getting installed.

Expected Results:  packages should be installed.

Additional info:
Comment 1 Jeff Johnson 2003-12-27 16:04:01 EST
URL non-functional, presumably because fixed some other way.

Please reopen if I'm wrong.

Note You need to log in before you can comment on or make changes to this bug.