Bug 103458 - RFE: s-c-network should handle big /etc/hosts files better
RFE: s-c-network should handle big /etc/hosts files better
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: system-config-network (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-30 23:30 EDT by Christopher Wong
Modified: 2008-01-11 17:20 EST (History)
0 users

See Also:
Fixed In Version: 1.4.7-1.fc8
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-11 17:20:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output of redhat-config-network-cmd (102.51 KB, application/x-gzip)
2003-09-18 12:20 EDT, Christopher Wong
no flags Details

  None (edit)
Description Christopher Wong 2003-08-30 23:30:56 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.76 (Linux 2.4.20-19.9 i686; U) Opera 7.11  [en]

Description of problem:
The redhat-config-network GUI hangs when trying to save changes.

Version-Release number of selected component (if applicable):
redhat-config-network-1.2.15-1

How reproducible:
Always

Steps to Reproduce:
1. Start redhat-config-network
2. Edit eth0. Check/uncheck some option.
3. File->Save. 
    

Actual Results:  redhat-config-network sits there frozen. GUI is frozen: will 
not refresh when the window is obscured and restored. Top shows 90% CPU usage.

Expected Results:  redhat-config-network should update my network configuration.

Additional info:

I recently removed pump and dhcpcd packages from my system (leftover from prior 
RH versions) and installed dhclient.
Comment 1 Harald Hoyer 2003-09-01 11:07:54 EDT
do you run redhat-config-network on a remote machine?
Comment 2 Christopher Wong 2003-09-01 12:31:21 EDT
Not in this case. Everything's local.
Comment 3 Harald Hoyer 2003-09-02 05:34:58 EDT
please attach the output of:
# redhat-config-network-cmd
Comment 4 Christopher Wong 2003-09-18 12:20:15 EDT
Created attachment 94587 [details]
Output of redhat-config-network-cmd

The file is long because of the presence of a large /etc/hosts file (used to
block banner ads in web pages).
Comment 6 Fedora Update System 2007-12-06 15:44:42 EST
system-config-network-1.4.7-1.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update system-config-network'
Comment 7 Fedora Update System 2008-01-11 17:20:18 EST
system-config-network-1.4.7-1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.