Bug 103460 - Default monitor resolution for Nokia 447Za incorrect
Default monitor resolution for Nokia 447Za incorrect
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-xfree86 (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-31 03:49 EDT by Thue Janus Kristensen
Modified: 2007-04-18 12:57 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-16 14:54:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thue Janus Kristensen 2003-08-31 03:49:50 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030827
Debian/1.4-3

Description of problem:
The default monitor resolution for my Nokia 447Za chosen during installation is
way off. Bad enough that X wouldn't run before I corrected the resolution.

It does detect the monitor correctly.

These are the correct values, taken from my monitor manual:
HorizSync	31-68
VertRefresh	60-85

Version-Release number of selected component (if applicable):
(the one that came with RH9)

How reproducible:
Always

Steps to Reproduce:
1. Reconfigure X with a Nokia 447Za monitor
2. ...
3. Profit! (You must have heard that joke before...)
    

Additional info:
Comment 1 Thue Janus Kristensen 2003-08-31 03:55:21 EDT
Sigh - Iam not awake yet. I meant "refresh rates" where I said "resolution"
above. Sorry about that.

Now that I am at it, the best resolution (Yes, I do mean resolution) to run a
Nokia 447Za under is 1152x864, not 1024x768 as is default. (It maximizes screen
area under acceptable refresh rate; I saw this recommened in reviews of the
monitor, and I agree).

MVH
-Thue
Comment 2 Brent Fox 2003-10-15 22:50:18 EDT
Are you sure?  Looking around on the web, I've found some differing data.  

On page 3 of http://sara.kgcomputer.com/documents/monitors/GA771.pdf, it says
that the Nokia 447Za does Horizontal 31-71 kHz and Vertical 50-120.

Then, on http://press.nokia.com/PR/199707/778221_5.html, it says the 447Za, "is
capable of a maximum refresh rate of 120 Hz, and has a horizontal frequency
range from 31 to 72 kHz."

Then, on http://press.nokia.com/PR/199903/777132_5.html, it says, "Top
horizontal frequencies range from the Nokia 447ZA's 86 kHz"

So I don't know what to believe.  As root, try running '/usr/sbin/ddcprobe' and
see if the monitor returns the refresh rates from the firmware.
Comment 3 Thue Janus Kristensen 2003-10-16 05:42:49 EDT
I can't find my manual right now, but those values I wrote was what it said.

Running ddcprobe supports rh's values:
---------------------
[root@kg31 thue]# /usr/sbin/ddcprobe
 
Videocard DDC probe results
Description:  Intel Corporation Intel(R) 815 Chipset
Memory (MB):  1
 
Monitor DDC probe results
ID: NOK00ba
Name: Nokia 447Za
Horizontal Sync (kHZ): 30-72
Vertical Sync (HZ)  : 50-120
Width (mm): 300
Height(mm): 230
---------------------

(note that the first link you gave was to another monitor model)

I think I have to retract the claim that the rates setup caused X to fail. I
tried installing the new rh beta, and even though it was configured with the
same rates X works fine.
I don't know why X failed to work when I installed RH9, and I don't know why
reconfiguring fixed it. I just assumed that since those values were at odds with
my manual (and chosing them differently in reconfigure made X work) that they
were at fault.
Comment 4 Brent Fox 2003-10-16 14:54:45 EDT
Ok, well, the vaules that the firmware returned (50.0-72.0) and (50.0--120.0)
exactly match what we have in the MonitorsDB file, so I think we should leave
the refresh rates alone.  I'm going to close as "Rawhide" since the problem does
not appear in the Fedora beta.

Note You need to log in before you can comment on or make changes to this bug.