Bug 1034714 - Regression in 3.8.1 causes breakage in Tracker's SPARQL queries
Summary: Regression in 3.8.1 causes breakage in Tracker's SPARQL queries
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: sqlite
Version: 20
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jan Staněk
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker
Keywords:
Depends On:
Blocks: F20FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2013-11-26 11:47 UTC by Debarshi Ray
Modified: 2013-11-29 13:54 UTC (History)
8 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2013-11-29 13:54:34 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 711510 None None None Never

Description Debarshi Ray 2013-11-26 11:47:44 UTC
Description of problem:
Updating to sqlite-3.8.1-1.fc20 from sqlite-3.8.0.2-4.fc20 causes the collection/album functionality in gnome-documents and gnome-photos to break. See: https://bugzilla.gnome.org/show_bug.cgi?id=711510


Version-Release number of selected component (if applicable):
sqlite-3.8.1-1.fc20


How reproducible:
Every time.


Steps to Reproduce:
1. Install gnome-photos.
2. Create an album from your local photos, or if you have sets in your Flickr account you can add your Flickr account via Online Accounts in Settings.
3. Once you have an album, double-click it to see what is inside.


Actual results:
The album will show up and its thumbnail will be a collage of the photos inside it, but when you click the album nothing will show up inside it.



Additional info:
Both gnome-documents and gnome-photos speak SPARQL with tracker, which in turn translates them and speaks SQL with sqlite.

Comment 1 Debarshi Ray 2013-11-26 15:49:30 UTC
After some back and forth on the sqlite Git mirror [1] I found that it has been fixed in master. Particularly this commit appears to fix it:

commit c098d918e1e19088be9659c409f1a6fa32b0efe6
Author: D. Richard Hipp <drh@hwaci.com>
Date:   Mon Oct 28 20:15:56 2013 +0000

    Do not use transitive WHERE-clause constraints on LEFT JOINs.
    Fix for ticket [c620261b5b5dc].

I am going to build a Fedora package with this commit cherry-picked and if it does not break anything we can hopefully push it to stable.

[1] http://repo.or.cz/w/sqlite.git

Comment 2 Fedora Update System 2013-11-26 16:14:52 UTC
sqlite-3.8.1-2.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/sqlite-3.8.1-2.fc20

Comment 3 Adam Williamson 2013-11-26 16:41:50 UTC
Proposing as a final FE as this breaks behaviour in apps people may want to run from the live images.

Comment 4 Fedora Blocker Bugs Application 2013-11-26 16:43:46 UTC
Proposed as a Blocker for 20-final by Fedora user rishi using the blocker tracking app because:

 Proposing as a blocker because it adversely affects the functionality (ie. collections) of a default application (ie. gnome-documents).

Comment 5 Fedora Update System 2013-11-26 18:03:29 UTC
Package sqlite-3.8.1-2.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing sqlite-3.8.1-2.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-22183/sqlite-3.8.1-2.fc20
then log in and leave karma (feedback).

Comment 6 Mike Ruckman 2013-11-26 18:27:43 UTC
+1 FE - this would be good to get into TC3.

Comment 7 Jóhann B. Guðmundsson 2013-11-26 18:35:59 UTC
+1 FE

Comment 8 Kevin Fenzi 2013-11-26 18:38:22 UTC
+1 FE

Comment 9 Adam Williamson 2013-11-26 18:42:47 UTC
Setting AcceptedFreezeException with four votes, thanks.

Comment 10 Adam Williamson 2013-11-27 18:22:26 UTC
Discussed at 2013-11-27 blocker review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2013-11-27/f20-blocker-review-3.2013-11-27-17.01.log.txt . Accepted as a blocker per criterion "All applications that can be launched using the standard graphical mechanism of a release-blocking desktop after a default installation of that desktop must start successfully and withstand a basic functionality test." - https://fedoraproject.org/wiki/Fedora_20_Final_Release_Criteria#Default_application_functionality ; the functions of Documents and Photos in question are pretty basic.

Comment 11 Adam Williamson 2013-11-28 01:33:28 UTC
Tested, with the updated sqlite and a restart of goa-daemon (it doesn't seem to autorespawn; after killing it, I had to manually launch it again...), Photos works great.

Comment 12 Fedora Update System 2013-11-29 13:54:34 UTC
sqlite-3.8.1-2.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.